0

I was wondering if anybody has had a similar issue to this before; i attempted to update my OS from Snow Leopard to Mavericks, and when told to 'enable journaling' on my hard disk, i did just that, and within minutes the computer crashed with this error:

panic(cpu caller 0x3044262): "jnl: transaction too big (1569280 >= 1572352 bytes,
    bufsize 4096, tr 0x8b4cfac bp 0x57e8fcf0)"
    @/SourceCache/xnu/xnu-1504.15.3/bsd/vfs/vfs_journal.c:2481

Ever since it has been throwing the same error literally on startup, just as the musical note hits with the apple symbol. when i try to boot from a boot disk or go in to safe mode, it hangs on a little longer but always ends the same. I can get into single-user mode but the commands are strictly read-only. Any attempt to mount -uw results in the same error message and the computer locking up again.

I've also noticed "jnl: unknown-dev: journal start/end pointers reset!" appearing when i go into single-user mode. Once in single-user mode my hard drive is exactly how i left it, with all the files in the right place, but i just cant use them.

I've tried using fsck -fy on the root but it says the disk is fine!

Any help would be much appreciated!

  • Are you in a state where the mac no longer boots or just looking for advice whether you can upgrade without journalling? – bmike Nov 25 '13 at 20:21
1

OK, so this problem had me tearing my hair out and cursing the big one upstairs for picking on me, but the solution I found to work is shown below:

Firstly, and this might not be necessary, but I used my Apple Application Installation DVD and held down the D key on boot, which tests the hardware to see if there are any errors. I tried both the quick test and the long test, together taking around an hour.

Secondly I reset the PRAM. I'm fairly sure this did nothing to help my cause, but I put it here for a more complete answer. Hold down Command / Control / P and R, all at the same time as the computer is booting. It will reboot, at which point you can pull your fingers out of that weird position.

Next, and I believe this to be the most important step, load Single-User mode on boot (Command + S). Once the command prompt is ready you should see somewhere in the verbose type above it a drive (something like /dev/disk0s2). What I did now was to use

/sbin/fsck_hfs -f -d /dev/disk0s2

This debugged and fixed the drive in question, and upon using the 'reboot' command in single-user mode, the computer started up fine, and has been as good as gold since!

Regardless, this has taught me to back up my drives and also reinstall my OS on a new HD.

Hope this helps anyone in the same leaky boat! Ste

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .