0

I have a unlocked iPhone 4 or at least that's what I've been told when i bought it. But then I went ahead to unlock it again, when I put a SIM card in, it says no service or at least i hope that's what it's suppose to say. Any hoo I just updated my phone to ios 7.0.3 or whatever and I tried putting in someone else's Verizon and Sprint SIM cards in but it will not get past activation. It says SIM is not valid but when I put the SIM in for activation, but it says no service, which is a good thing. I've been told to try T-Mobile or ATT&T SIM card and reboot it to get past activation. I have just purchased a Straight Talk SIM card and I am hoping to transfer over to them and hoping the SIM card works or any SIM card to get past activation. Any advice or a solution to my promblem?

  • Can you please edit your question to clearly say what your problem actually is (the part about T-Mobile/Straight Talk) is probably not part of the problem description)? It would also help if you could add some details about whether it worked correctly before the upgrade to 7.0.3 (and from which version you upgraded) and why you had to unlock it again. – nohillside Nov 25 '13 at 18:08
  • When you say unlock - do you mean slide to unlock the device or that when you restore your iPhone for iTunes it tells you congratulations, you are carrier unlocked? – bmike Nov 26 '13 at 13:54
1

Phones are a bit tricky. On one hand, the manufacturer (Apple) should make it clear how to use the device, but since you get a no-service error that part of the equation seems working well enough.

If the device shows no service with several known good SIM, you might need to check with Apple or the carrier that originally locked the device to verify it's unlocked + test with an active SIM from that carrier.

If you can use the phone on wifi, it's activated (in the technical sense - activation is a specific step needed before the phone software starts to operate) and now you can focus on establishing cellular service and troubleshooting that portion of iOS:

You must log in to answer this question.

protected by Community Mar 24 '15 at 20:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .