1

I have a 256 GB SSD installed in my Macbook Pro. Today I observed that Finder tells me that I have a free disk space of 247.51 GB, which is unquestionably wrong.

At the same time, in System → About this Mac, I can see I have 44.73 GB of available disk space. I think this number is more accurate, but it tells me that 202.78 GB of used space is backup, which is not right. I do not know the actual size of backup files, but my personal files take about 125 GB, so there cannot be 200+ GB of backup files.

I'm confused. What's happening to my computer?

Edit: This is the related snapshot, the size given by Mavericks are slightly different then yesterday, but it's still not making sense. I believe DaisyDisk's report is right.

The 256 GB SSD is the only hard drive that I have installed. I replaced the original HDD with it.

disk usage

Edit 2: Today the available disk space gone crazy. It shows that I have 265.06 GB available...

  • could you give a bit more information? do you only have the SSD installed? external harddrives? where does time machine backup to? could you post/screenshot the information from System->About This Mac->More Info...->Storage – CML Nov 23 '13 at 15:06
1

First off, I do not think that your file system is corrupted or broke. But you can verify this by booting from Recovery HD (to do this start your laptop while holding the keys "Command" and "r" pressed)(I am assuming you are 10.7+), you should then come to a screen where you can start Disk Utility. There you can run Repair Disk Permissions and Repair Disk. If it runs without errors and/or fixes everything, you are good to go.

From your screenshot I can gather a few things. In brackets which window I gathered the info from:

  1. SSD with 256GB (About This Mac)
  2. 210.9GB taken (Daisy Disk, this is the total amount used by your system)
  3. Backups 149.32GB (About This Mac)
  4. MobileBackups 95.2GB (DaisyDisk)(see answer by Brad Allred: local snapshots here link again, so the Backup can be bigger than the backuped files because there are several backups present)
  5. 193.59GB free (Macintosh)
  6. 44.3GB free (About This Mac)

I think what is confusing you is points 5. and 6.

This can be explained if you look at the difference: 193.59GB-44.3GB=149.29GB which comes quite close to the third point: Backups 149.32GB (a small error comes from conversion and rounding). The difference is that the Finder calculates the free space you can use (the backups would be deleted if necessary). But the About This Mac window and DaisyDisk show the SDD as is so with the Backups.

This link explains snapshots and your situation quite well. The different free space sizes and how to turn off snapshots. In terminal: sudo tmutil disablelocal (this will immediately delete local snapshots)

  • Thanks. I try to disable local snapshot and remove parallels desktop *.pvm files, finder tells me that I have 300+ GB, but after restarting, problem solved. Maybe it's a bug in Mavericks. – Renfei Song Nov 24 '13 at 16:41
2

you are on a laptop using time machine. time machine uses local snapshots on portable computers. they are stored at /.MobileBackups if you want to have a look and verify how much space it is consuming.

  • I had the same problem. Disabling then re-enabling time machine seemed to work for me (after waiting a few minutes that the free space display is updated) – lauhub Apr 17 '14 at 10:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .