7

My question title probably sounds confusing, so allow me to explain...

Let's say you have an iPhone 3GS that's still running iOS 5. Is it possible, today, to upgrade that device to iOS 6 (the latest supported version)? Or is it now stuck on iOS 5 because the latest version, iOS 7, doesn't support the 3GS?

Put another way, if you were to go to Software Update on that device, would it offer you an update to iOS 6, or would it say nothing is available because iOS 7 isn't compatible?

  • I'd be glad to be wrong, but it is my understanding that Apple disabled the authorization servers which validate iOS 6, so if you haven't updated by now, chances are extremely high that you won't be able to upgrade it now. – TJ Luoma Nov 23 '13 at 5:31
  • 1
    Ah, right. Actually the reason why I'm asking is because I have an iPhone 4 that I'm keeping on iOS 6 for the time being. If iOS 8 comes out next year and drops support for the iPhone 4, I'd like to update it to iOS 7 at that point instead of getting stuck on 6 forever. But since that's all hypothetical, I figured I'd ask the question in a way that can be verified today. – daGUY Nov 24 '13 at 23:54
  • See my answer here: apple.stackexchange.com/a/110585/18387 – Andrew Larsson Dec 3 '13 at 0:04
  • @daGUY Is it an old bootrom 3GS? – Andrew Larsson Dec 4 '13 at 17:41
  • Duplicate: apple.stackexchange.com/q/102928/113578 – Owen Blacker Feb 13 '15 at 11:30
2

To give a clear answer to the question that was asked, which is whether a device can be updated to the latest version of iOS it supports, even if that version of iOS is no longer current.

Yes, it is possible. Software Update, either on the device or via iTunes, will offer the latest version that is supported by your device.

I can't readily find an official reference for this but it is supported by numerous other answers to similar questions on this site.

  • On re-reading @TooAToB's answer, they did actually answer the question, so I've modified the wording of my own answer - but I still feel it's worth having a clearly stated version. – nekomatic Sep 8 '16 at 14:29
1

Normally you should be able to update via iTunes (in this case, further information on that below).

If that doesn't work you need to look what model Nr. the iPhone is (something like A1429, for example) and download the appropriate iOS software (about 1 GB). By alt-clicking on the update-button in iTunes you are able to select a specific package you want to update from. Select you downloaded package and wait until the software ist installed on the phone. You should be able to install the most recent version of iOS for your iPhone model this way.

If you're experiencing any problems with this, let me know.

  • 1
    See my answer here for details on why your answer is not correct: apple.stackexchange.com/a/110585/18387 – Andrew Larsson Dec 3 '13 at 0:04
  • 1
    Look to the question, there is no jailbroken phone here. its a 3GS where newer software isn't even supported. iOS signs just fine on a phone where iOS 7 can't be installed... + I did this by myself with more than 1 not jailbroken phone. – TooAToB Dec 3 '13 at 17:30
  • 1
    My answer is relevant to both users of jailbroken and non-jailbroken iOS devices. I wrote it to be a universal answer. – Andrew Larsson Dec 3 '13 at 17:35
  • You did not read the 3GS part, did you? – TooAToB Dec 4 '13 at 13:31
  • 1
    Updated my answer so it's less confusing for general problems in question of this topic – TooAToB Dec 5 '13 at 14:26
1

I was recently looking for the same thing. We develop iOS apps and we wanted a way to test our app with older versions of iOS. Here's what we found to work well:

  1. Download the iOS ipsw you want. We use http://www.getios.com/
  2. Connect your device to a PC running iTunes and navigate to the device page.
  3. Hold down the 'Shift' key on your keyboard and click the 'Update' button. Select the ipsw file and iTunes will install this version.
  • On the Mac version of iTunes 12.5.5.5, hold down the option (alt) key instead of the shift key. – Mike Mar 10 '17 at 0:13
0

Apple discontinues signing old versions of iOS after a certain period (normally days to weeks for OS's only one or two minor versions out). When your iDevice updates to a new OS, it calls home to verify the OS installed is allowed.

Since Apple no longer signs old OS's, sadly you can't downgrade very far.

Note: there are 'hacky' ways of doing this involving 3rd party tools -- but I didn't believe that to be the intent of this question so I didn't delve into those topics.

  • 2
    I'm going to have to disagree with Andrew and Jimmy. Although it's true that Apple stops signing old versions of iOS, they continue to sign the last supported firmware version for legacy devices. The iPhone 3GS is the iPhone 2,1, and as you can see here, Apple is still signing iOS 6.1.6 for the 3GS. – user192195 Jul 14 '16 at 21:28
0

Check signed versions of iOS on ipsw.me for your device. If you see that older version of iOS is still signed by Apple, you can upgrade to it, but not through iTunes. Because iTunes always upgrades your device to the latest version. To upgrade my iPad from 11.4.1 to 12.1.1 ( which was signed at that time, the last version was 12.1.3 at that moment) I used iMazing app on my Mac. Working version you can download from here: https://rutracker.org/forum/viewtopic.php?t=5651755 Requires registration. Also you need to upgrade your iTunes on your Mac to the latest version. IPSW file of your desired version of iOS you can download from ipsw.me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .