1

I've got a 15-inch MacBook Pro with the latest OS X. Every time I reboot, it resets the keyboard layout to American English even though I set it to Swiss German. This means that I always need to go to the language settings and change it to my layout, which is quite annoying.

Any suggestions how to solve this?

I also posted this question on Apple Support Discussions but wasn't getting any answers.

1

Things you could try:

  • Run sudo rm ~/Library/Preferences/com.apple.HIToolbox.plist ~/Library/Preferences/ByHost/com.apple.HIToolbox.*.plist /Library/Preferences/com.apple.HIToolbox.plist and restart. The current keyboard layout is stored in the first file in 10.9 and the second file in 10.8. The keyboard layout used in the login window and by the guest account is stored in the third file.
  • Run open -a KeyboardSetupAssistant to identify the keyboard.
  • Run sudo rm /var/db/.AppleSetupDone;sudo /System/Library/CoreServices/Setup\ Assistant.app/Contents/MacOS/Setup\ Assistant and create a new account. Set the default keyboard layout to Swiss German in the second step and enter anything else in the other steps. You can delete the account after you have created it.
  • I had a problem where the keyboard got set to US after a OS X upgrade. The fist one worked for me. Thanks! – Daisuke Shimamoto Oct 15 '16 at 4:49
0

Had the same issue and the following worked for me. Run in Terminal:

sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/

then do:

sudo chmod 644 /Library/Preferences/com.apple.HIToolbox.plist

Afterwards restart without logging out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .