1

Two days ays ago I closed the lid of my macbook pre for the night as I have done for the last 2.5 years but when I opened the lid in the morning the screen didn't show. It seemed to be 'alive' (ish) i.e. the volume buttons made a clicking sound but when I tried to do a restart with keyboard shortcut there was no response so I had to shut down with the power button.

When I tried to start up again it got stuck on a grey screen with the laptop running hot. I powered off again and tried to boot recovery partition but got a scrambled blue screen with that. Tried to boot bootcamp and got a dead screen like the laptop was off. Tried to boot from a usb blue scrambled screen again.

I reset smc, pram etc. but nothing made a difference.

After trying the various boot options a few times of these I plugged in the power cable and all of a sudden I was able to boot into OS. Problem was that if the laptop went asleep the same thing would happen again and only after numerous restart attempts would it boot but once up and running no issues.

Possibly unrelated but maybe not, today all of a sudden the laptop got really hot so I loaded activity monitor to see what was going on but I couldn't open it as it kept hanging. Two restarts later and the problem disappeared.

Unfortunately the boot issue and the dead OS after sleep remains an issue, any ideas whats going on?

A few details on my setup - I'm running an early 2011 MBP with OS 10.9, I have 16GB RAM, a Crucial M4 SSD and the original HD in an optibay in place of the superdrive.

1

That is a tough one and some of the symptoms seem to indicate hardware issues but the fact that it came back to life may put the lie to that conjecture. Since you already reset the SMC that is also out. More troubleshooting steps around power issues (including resetting the SMC) in the Apple KB here:

http://support.apple.com/kb/HT3964

Some of (all?) of these steps may be redundant depending on what all you have done.

It sounds like there may be a software issue as well. I use Onyx for general system maintenance and have found it works well and causes no problems. That may be worth a shot.

However once you have gone through that and the issue still remains you may have an intermittent hardware issue.

If you have upgraded the RAM yourself, you can try removing the DIMM you installed. Same for any HD/SSD upgrades you may have done yourself.

Failing that it may be time for a visit to your local Genius bar...

  • Hi Steve, thanks for the reply! I've been doing some googling and it looks like it could possibly be a GPU issue which most likely means a logic board replacement if thats the case :( Strangely though there is no sign of any problem this morning so I'm gonna wait a while before I take that drastic step! In the mean time I'll give Onyx a try. I've also read that there may be a fix for this in 10.9.1 so I might wait for that too – doovers Nov 22 '13 at 21:54
  • If it IS the GPU and a hardware problem it is intermittent which is not uncommon at all. So keep a good backup handy and be prepared for it to brutally enforce Murphy's Law at exactly the wrong time. Good luck! – Steve Chambers Nov 23 '13 at 1:22
  • Ha ha good advice :) I've been 'time machining' and CCCing like a man possessed for the last couple of days!! – doovers Nov 23 '13 at 1:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .