Even after the 7.0 (1822) update, Mavericks Mail is not keeping synchronized with the GMail IMAP server. A mailbox with hundreds of messages in it suddenly has only the latest added message. Then it will show only messages added since that message.

I have tried mailbox Rebuild, re-checking mail, close Mail and open it again. Nothing seems to help. The messages in the Mail mailbox don't match what's in the filter by label on the web interface.

Is there a way to force Mail to re-synchronize a single Mail mailbox (to a GMail label) without deleting the entire account and spending another day or two rebuilding the whole database?

A related question asks about messages in Mail (inbox) that are not in GMail (inbox). This question is the reverse, messages in GMail (archived label) that are not in Mail (mailbox). The answer may or may not be the same!

NOTE: After 5 days of daily use, the mailbox has just restored itself. That's a long time to wait! Unfortunately, for the time being (until I detect a recurrence of the problem) it will be difficult for me to evaluate the effectiveness of solutions offered.

3 Answers 3


If it happens again, try the following:

  • Right click any Gmail folder that is missing messages and select "Get Account Info".

This forces Mail to search through the entire Gmail account for messages and will restore missing messages in all folders for that account.

The missing mail problem occurred for me when I upgraded from Mountain Lion to Mavericks 10.9.1 with Mail 7.1 (1827). I had unsuccessfully tried:

  • clicking "Get new messages in all accounts"
  • synchronising the mailbox
  • taking the account offline and then back online
  • rebuilding the mailboxes
  • un-enabling the account, restarting Mail and then re-enabling the account.

Only getting the account info solved the problem for me.

  • This sounds very promising. +1 for reminding me of Get Account Info, which I very rarely use. I'll come back and approve this answer if I see the problem again and can confirm that it works for me. Commented Jan 20, 2014 at 22:48
  • BTW, this did not work. Ultimately, I had to completely give up on Apple Mail; the Mac would at times become completely unresponsive servicing Mail and TimeMachine. Switching to using the GMail web interface exclusively has "solved" all my problems. Too bad. Commented Jun 8, 2014 at 19:38
  1. In Gmail, go to your Labels settings and on the "All Mail" line, uncheck "Show in IMAP".
  2. Relaunch Mail, missing messages will repopulate.

Note on mail archiving:

  • When "All Mail" is shown in IMAP, the Archive for that account is the "All Mail" which includes non-archived content, which is part of the problem.

  • With "All Mail" not shown in IMAP, using the Archive feature in Apple Mail will move messages to a gmail label, "[IMAP]/Archive"

  • If you want all previous archived messages to be moved into this new Archive folder you need to search in Gmail for has:nouserlabels -label:inbox and move old conversations to the "[IMAP]/Archive" label. However this search will include conversations that have some of the messages still in the inbox or some other label. So be careful.

  • This sounds like the solution for Smart Mailbox problems as discussed on discussions.apple.com; this does not seem to be my problem (I don't use any Smart Mailboxes; I do all filtering using GMail filters). Commented Nov 26, 2013 at 19:53
  • I believe that point 1 is wrong for Mavericks (it was correct for ML). You should (must?) enable Show in IMAP for the All Mail folder.
    – Gilby
    Commented May 7, 2014 at 0:36

Go to Mail's menu bar and choose Mailbox > Synchronize > [The mailbox you want to synchronize].

This will sync the chosen mailbox with the server to get folders and emails to match those on the server.

If you still don't see emails you're able to see in Gmail's web interface then Mail 7 still has some troubles syncing correctly. Apart from re-downloading all your email in a newly setup local account the only you can do is to wait for Apple to fix Mail 7.

  • I had tried Synchronize; it does not work. Commented Nov 26, 2013 at 19:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .