0

I have a problem opening my .csv files in Excel; when importing them, all the information is in one column. How do I get Excel to separate the information automatically into different columns?

I have a MacBook Pro and I’m using Excel 14.3.8.

1

It is interesting that if you really have a comma separated text file, you actually have to select the comma separator, the only separator that is selected by default is "Tab".

  1. Select the CSV file to import.
  2. Select "Delimited" in the "Text Wizard Import 1 of 3" dialog.
  3. Make sure the "Comma" checkbox is checked in the "Text Wizard Import 2 of 3" dialog.
  4. Unselect "Tab" if you have tabs embedded in your data in the same dialog.
  5. Continue with the text wizard dialogs and select finish.

The final screen, when "Finish" is enabled, will show a sample of how your data will be imported so you can see before you finish that it will be properly separated into columns.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .