13

I actually want to boot Linux but since that is not working I'm thinking some one might know on the Apple end.

If there's a way to boot Mac from a USB stick, then booting another operating system should not be impossible.

Do I need to use an Apple bootloader to trick my PowerBook into thinking it's booting Mac OS and then slip in the Linux disc or what?

11

I have done this many times since I posted this question.

  1. Create usb stick like this:

    sudo dd if=/<path to iso file>/<name of iso file> of=/<path to usb stick> bs=32768 conv=notrunc,noerror,sync
    
  2. Put the USB stick into your Mac and press the power button while holding down Command ⌘+Option+O+F

  3. At the prompt, type the following:

    boot usb1/disk@1:,\\yaboot
    

Note: If you are booting linux then use ,\\yaboot, but if you are booting a Mac OS use ,\\tbxi.

Note 2: If your stick is in the right side of the machine, then you need to do this:

boot usb0/disk@1:,\\yaboot

Note 3: If these commands don't work, then there is most likely a problem with your media or iso file.

I have found that Ubuntu, Debian, and openSUSE work great. I cannot get Fedora or Gentoo to boot this way yet. My optical drive does not work anymore, so this is how I install OS X on my machine. I made a live USB stick of the OS X install disc this way.

  • Thank you for your answer, I've found it really useful. Now, I don't know if you found out how to boot Gentoo same way, but I did, so I wanter to share the link that helped me do that. Here it is. Hope it helps! en.gentoo-wiki.com/wiki/LiveUSB_on_PPC#Boot_from_Open_Firmware – user25691 Jul 24 '12 at 16:49
  • thank you so much! this is the best "tutorial" regarding this topic i was able to find. just successfully bootet xubuntu 12.04 mini install iso from USB, because my superdrive in my beloved powerbook is broken. – harald Dec 30 '12 at 16:19
  • Got there while trying to boot a Ubuntu from a USB stick. You can also type dev / ls to get a tree-shaped listing of devices and see which usb has a disk leaf node. Even if the path to that node looks like /usb@1b/disk@1 (notice extra @ and b), the correct path still looks like boot usb1/disk@1:2,\\yaboot – Stéphane Gourichon Apr 4 '14 at 20:36
  • I can confirm that this works with an iBook G3 M6497 as well, thanks! – ToastyMallows Nov 22 '16 at 4:52
3
boot usb1/disk@1:,\\yaboot

OR

boot usb1/disk@1:,\\tbxi

is not a complete command. You need to list a partition number after the ":"

for example, if you are trying to install on a Mac, you will need to enter something like this

boot usb1/disk@1:10,\\tbxi

(where "10" is the partition number of the usb drive, disk@1 in this example).

To find out the partition number where OSX is located on your USB, use Disk Utility, Click on the partition you set up with OS X and then R-click or Ctrl-L click and select "Information".

You will get something to the effect of: disk1s10

s10 is the partition number. Refer to the example above.

2

This thread is old, but i want to add some information that may be useful:

On a Powerbook G4 A1138 (1,67 Ghz 15" late 2005) the above instructions didn't work out of the box. I used the finnix ppc rescue ISO, dumped with dd to the usb key.

1.) OF creates the devalias ud for the usb key in the left port. This ud alias maps to /pci@f2000000/usb@15/disk@1

2.) You can call yaboot with boot ud:2,\\yaboot - but then the kernel will panic because it still searches his initrd + rootfs somewhere at cd:2,/ ... (the cd alias is hardcoded inside files like ofboot.b, yaboot.conf ... on the ISO)

3.) Quick and dirty workaround: overwrite the cd alias in OF with the path to your USB Key (copy the path from the ud alias): devalias cd /pci@f2000000/usb@15/disk@1

4.) Now boot with boot cd:2,\\yaboot

5.) No problem anymore with hardcoded cd alias - it's now poiting to your USB Key. You can just choose a default kernel entry - *finnix in my case - and it will boot properly.

The alias will be resetted to default at the next cold boot and thus you will have to repeat the procedure for every USB-boot.

1

I've heard that using Super Duper works well for this. I imagine if that's the case, then Carbon Copy Cloner should work as well.

Deploy the image onto the USB through one of those utilities and you should be golden.

Find Super Duper! here.

  • So using dd in the terminal has problems? – Joshua Robison Mar 31 '11 at 5:55
  • And I don't need to partition my USB stick or instal yaboot etc? – Joshua Robison Mar 31 '11 at 5:55
  • I wouldn't mess around with firmware/bootloaders, personally. I've just heard from colleagues in the business (I am an Apple-certified tech) that this works well. – Harv Mar 31 '11 at 8:30
  • SuperDuper and Carbon Copy Cloner are good tools to copy bootable systems, but the issue in this question is hinged on PowerBook G4 models not formally allowing USB boot. So the cleanest OS copy created won’t boot on these systems without extra firmware adjustments as outlined in the above answers. – JakeGould Dec 8 '14 at 18:50
  • @Harv You’re welcome. And if you want to see how I stumbled across this question and answer thread, please check out this thread on Super User. – JakeGould Dec 8 '14 at 19:21
1

so in my experience i've learned that on my Power Book G4 1.5 (A1106) that

boot usb1/disk@1:10,\tbxi was not helpful. try this

  • enter image description here

  • command, option, O, F (open firmware)

  • release keys
  • boot ud:3,\:tbxi

if you're lucky it might work. i tried without the 3 and i got the prohibitory sign, everything else wouldn't work. Edit: i just got the prohibitory sign so i think my system has a problem

1

What worked for me on a Cube G4 was the following (based on Joshua's advice):

  1. I formatted my USB thumb drive in Disk Utility with Apple Partition Map and a MS-DOS (FAT) partition. diskutil list should bring something like this up:

freshly erased usb stick with apple partition map & fat32 part

  1. Now let's for the sake of it nuke the FAT32 partition: sudo pdisk L e /dev/rdisk2 d 2 w and exit CTRL+C. The entire process should look something like this: enter image description here

The deeply cleansed disk should appear like so (diskutil list)

enter image description here

  1. Now we can copy over the Mac OS X 10.5 Leopard ISO with dd: sudo dd if=/<path to iso file>/<name of iso file> of=/<path to usb stick> bs=32768 conv=notrunc,noerror,sync. It should be something like this:

enter image description here

  1. Depending on your stick, this might take upwards of a few hours (even with a badass USB3 one!). At the end, diskutil list should show something like this:

enter image description here

  1. Plug this into your G5 Cube, and, at boot, press both ALT keys (theoretically one should work but with my wireless keyboard the both button approach works best)

  2. You'll get a very primitive version of the present day Boot Selection screen, WHICH ONLY WORKS WITH A MOUSE ! There you'll find the USB Stick and be able to boot from it, and install as if it were a very speedy and silent DVD drive :)

For those wishing to install Mac OS X 10.4 Tiger, the ISO floating around for that seems to contain a very small Apple_Driver_ATAPI partition (disk2s2 in step 4), a few KB instead of half a GB. This unfortunately seems to be incompatible with steps 1-6..

The workaround is the following: prepare a 10.5 Leopard USB stick, and overwrite the Apple_HFS partition with the Apple_HFS partition from the 10.4 Tiger disk:

  1. Proceed with creating a Leopard 10.5 stick as in steps 1-4

  2. Mount the OSX 10.4 Tiger image; it should look something like this: os x tiger disk partitions

  3. With dd, copy over the Apple_HFS (disk3s3 or diskNs3) partition OVER the Apple_HFS (~7GB) on the stick. This will leave you with a stick having the ATAPI driver from the Leopard DVD disc, but the OS image of the Tiger disc. Through this method, I got it to show, and managed to install Tiger alongside Leopard xD. On my end, it looks like this: enter image description here

For those wanting to install 10.3 or lower Unfortunately, I haven't found any way to get those to boot off of a USB device (not initially though).

To install 10.3 / 10.2 / 10.1 / 10.0, burn the CD1 image onto a disk, which you will have to be reading through the on-board IDE cable (connecting a USB cd-rom doesn't cut it, not USB allowed !). You'll install as per usual, pressing alt (both of them in case of the cube) at bootup, selecting the CD, installing ...

You'll at some point be asked to insert the 2nd disc - those you may prepare the same as a Tiger installation: make a Leopard disc, and overwrite the 3rd partition (the Apple_HFS one that occupies the most space) with the Apple_HFS partition of the CD2 of the pre 10.4 OS you're installing. This time the system will accept it and continue installing from the USB device.

0

Powerbook G4 1.0Ghz 12" External Pioneer/generic USB CD/DVD drive Plug into the rear-most USB port.

  • Power on
  • ⌘ CmdOptOF
  • boot usb1/disk@1:,\\yaboot
  • Return ⏎
  • restart

Installs Ubuntu 16.04 PPC perfectly, first try. Love these old threads and old machines!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .