I have a new(ish) MacBook Pro running OS X 10.9. When it boots up to the login screen it will let me move the cursor around, but it won't recognize click events.

I thought it was the trackpad, so I connected a wired mouse, and the symptoms persist.

After a little searching online I found that MacBook Pro owners have been having this same issue, and that Apple recommends closing the lid for 60 seconds, which causes some reset.

This has also worked for me, however, a few minutes into working, the cursor will stop accepting click events (even though I can still move it).

I can't keep closing and opening my lid every few minutes. Anyone got any ideas?

10 Answers 10

One of the most common causes of this is a magic mouse turned on in your laptop bag or somewhere similar.

Turning off bluetooth will ensure no remote button is being held down.

  • 10
    I had the same problem. The trackpad was not responding to clicks anymore, started to freak out while browsing any forum I could... Until I found my magic mouse clicked and stuck in a bag. Ah ah ah classic ! ;^) – user65331 Dec 20 '13 at 20:24
  • 4
    Felt pretty stupid after this one. I probably reset my comp a half dozen times before I realized this was the cause! – LunaCodeGirl May 18 '14 at 5:41
  • 2
    Add me to the club of people facepalming over this :D – funkylaundry May 20 '14 at 10:51
  • 2
    I joined the club @funkylaundry ! – Colin Fraizer Jun 16 '14 at 12:36
  • 7
    OMG! That is EXACTLY what happened to me. This is so helpful. Thank you so much! – MT. Sep 2 '15 at 5:48

I just had this problem and was resetting SMC and all kinds of other things. Then realized I had set something on my Magic Trackpad under my monitor, which was registering a click obviously so killed all other clicking. Make sure you eliminate that possibility!

  • Dude... you saved me so many hours of searching! embarrassed – FAS Jul 12 '15 at 21:40
  • 1
    Holy crap, I so needed this answer. Sure enough, I'd tossed a portable bluetooth speaker on top of my Magic Trackpad. Pick it up; problem solved. Facepalm! – Greg R. Jan 22 '16 at 12:40

I just had this problem too. What fixed it for me was enabling the Mouse keys in "System Preferences->Accessibility->Mouse & Trackpad" with the option to press the option-key five times to toggle the feature. Once you have this enabled press the "i" key to single click. I psuedo single clicked with the "i" key a few times and then my actual mouse clicks started working again.

Found a strange solution for the same issue with Mavericks on an iMac not clicking. However, while I couldn't click anything in the desktop, app windows or launchpad, I was able to click menu items.

My solution was simply to open the alert menu (default set to swipe two fingers from the very right edge of a trackpad, toward the left). The first time the menu appeared beneath the application windows, but the second time it moved the desktop and apps in normal fashion.

After that, I was able to click normally. Still don't know what caused the issue.

Typically they way I ask people to troubleshoot such problems is asking them if the issues exist using a freshly created new user account on the machine, and if the issues exist when they boot from the Recovery volume. If the answer to both is yes than the likelihood is that you have a hardware problem. If you don't experience the problem in a clean user account than you have an issue with your preferences or applications, and if you don't have the issue in the Recovery volume than you have a system wide issue a re-install will fix.

That said, if it's not a software problem cleared up by one of the above, I've seen similar issues that are hardware related where something presses up against the trackpad from underneath it. Sometimes this has been caused by a building battery in the MacBook, or something that has lodged underneath the trackpad. If there's pressure under the trackpad it will register as if the "mouse" is already clicked down and will also explain why adding another mouse or trackpad also exhibits the same problem.

Does the mousepad physically and noticeably "click" down when pressed? If not then it needs repaired of the issue underneath it fixed.

I thought I'd finally fixed the "mouse tracks but won't register clicks" issue by cleaning ALL battery contact points + & - in the belly of the mouse with rubbing alcohol on a swab. In my case, the + contacts were visibly "foggy"/dirty.

After doing so, clicking worked but my iMac behaved as if it wouldn't let go of the "down click" state, so, it lasso'd everything until I turned the mouse off. :(

SO, what actually WORKED was *holding down the POWER button on my Apple wireless keyboard" for a loooong time. Evidently, cycling the power on the wireless kybd "woke up" the proper functionality for my Apple Magic Mouse. (OF course, I trashed the various preference files before any of this, and un-paired & re-paired the bluetooth for the Magic Mouse). Turned my keyboard back on & now all is well... just had to re-enable the right-click functionality via Mouse System Preference.

I had the same problems as most of the statements and tried most of the suggestions to no avail. I finally reloaded Maverick, which takes a long time, using the Mac utilities. So far trackpad works like a charm. I don't know if Apple made some changes since Maverick first came out or the first load became corrupted but works great. Hope this helps as I know how frustrating the problem is.

  • Watch the video below. I think the buttons ware and the back of the trackpad touches whatever it is set on. I used key cards to check if that was my problem and problem solve with hardly any work. Good luck. youtube.com/watch?v=CXrKzzMUT4M – Alex Sep 22 '14 at 23:51

I Just had the same problem with my Macbook. Could not left click using the mouse or trackpad. Although the pointer would move and the right click is working.

The solution for me is to take out the battery. Then, the left click and trackpad works fine.

Also noticed the battery had a large bulge in the middle. I'm sure this is putting pressure on the trackpad from underneath.

Good Luck, Alan

  • This sounds like a battery ready to explode, change it. I've seen this quite few times. – sorin Feb 14 '16 at 11:09
  • And I can confirm, just happened to me, battery expanded, side effect touchpad not clicking anymore, ordering a new one. – sorin Feb 14 '16 at 21:18

What I surmise is that the Trackpad button is stuck clicking. This is disabling the button on any USB mouse that I connect. The Rowmote iPhone app must use a different comm HW/SW path. When I set the Accessability Preferences to ignore the trackpad when a USB mouse is connected, the mouse button works after I close & open the laptop.

So I can use a USB mouse until I replace the top case of the MacBook.

This is kind of the reverse or the problem or a BT mouse being stuck on inside a bag or laptop case.

So, what worked for me:

sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist ControllerPowerState 0

ps -A | grep blue # find the blued process ID
sudo kill -9 PROCESS_ID_NUMBER

Some more commands from: https://discussions.apple.com/thread/2619301?tstart=0

sudo defaults read /Library/Preferences/com.apple.Bluetooth.plist ControllerPowerState

sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist ControllerPowerState 0

sudo defaults write /Library/Preferences/com.apple.Bluetooth.plist ControllerPowerState 1 

sudo killall blued

sudo launchctl unload /System/Library/LaunchDaemons/com.apple.blued.plist

sudo launchctl load /System/Library/LaunchDaemons/com.apple.blued.plist

sudo launchctl start com.apple.blued

sudo launchctl stop com.apple.blued

protected by Community Nov 16 '14 at 2:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.