I've had my IPhone 4 since October 30th. Yesterday, it started acting funny. I can't receive text messages and when I do receive calls they go straight to voicemail. I'll get the voice mail several hours later. I can send texts AND make calls. I have reset everything on my phone and nothing has worked. I haven't updated anything on my phone because it is jail broken and I do not want to lose my games. Is it possible that because I have not updated it's acting up? I know it isn't my account. Could there be anything else wrong with it?

2 Answers 2


I don't think having a slight outdated OS or Jailbroken device would cause those glitches to occur. On my iPhone 4 it once acted funny in a different way by not responding to my finger taps correctly. Try this, it helped me:

  1. Hold the sleep/wake button on top and the home button at the same time. When the "slide to power off" slider appears keep holding the two buttons.
  2. When it appears to be off keep holding the two buttons still.
  3. Finally, when the boot apple logo appears you can release the two buttons.

This isn't a jailbreak technique that turns the phone into DFU or Recovery Mode. It's like a soft reboot that clears any lingering data on its RAM that might be causing your problems.

  • I think it might be a problem with the network. Ill have to get the account password and talk to AT&T. I've tried the reboot as well. Talking to AT&T is my last hope...next to taking it to the Apple Store. Thank you for the reply.
    – user4841
    Mar 30, 2011 at 22:32
  • Since it is a jailbroke phone, go to the SBSettings and tap on More. Under Mobile Substrate Addons turn off any cydia apps you are running (careful not to turn off something you don't recognize, they may actually brick your phone if turned off.). Then Respring. If the problem goes away then it is a cydia app that is causing the problem. @mattsnow had a similar problem using a tethering jailbreak app. Let me know how it went. If you don't have SBSettings, its easy to find it on Cydia.
    – Tsitra360
    Apr 4, 2011 at 0:27

Back when I had a 3G I had this exact problem. it was related to tethering being enabled via the http://help.benm.at/ hack. Reverted and things started working fine.

You must log in to answer this question.