Mail sent from a Mac (OS X Version 10.7.5 using Mac Mail, via Office 365 / Exchange) is appearing as it should when the mail consists of just text.

However, when there is an attachment added (in the case of my example a word document, but it's been the same for any file type) the email body text does not appear in the recipient's mail program (Outlook 2010 in this case) but is present as a .htm attachment - as is the signature added in Mac Mail.

enter image description here

If anyone's come across this or even better knows how to stop it from happening (My only thought so far was an encoding issue?), I'd be pleased to hear from you. There are a couple of open questions on this site which I think concern the same issue.

  • Do you attach the attachment at the very end of your email? If I remember correctly I once had a similar issue where the placement of the attachment lead to the whole email content being read as application/octet-stream (meaning here: an attachment) in certain webmailers, including Outlook. I think it could be fixed by attaching the files at the very end. Could you try that? There even is an option for this in the "Edit" menu of Mail.app, within attachments there is "Always Insert Attachments at End of Message" – Asmus Nov 19 '13 at 19:55
  • Hi, thanks for your reply. I'll get my user to try this out and let you know the result. I'm fairly confident that it IS a mail.app issue as composing a message with an attachment in the OWA via Safari behaves itself beautifully...(Yes, I know it should, but it;s always best to check and be sure!) – fire_an_ice Nov 20 '13 at 10:22
  • Just google for "exchange inline attachments" and you'll see that this is not an isolated issue ;-) – Asmus Nov 20 '13 at 13:08
  • Always nice to know there's more people suffering the same cr*p that you are :) Haven;t heard bck from my user yet, talking to him later today hopefully. – fire_an_ice Nov 22 '13 at 11:53

You must log in to answer this question.

Browse other questions tagged .