3

Whenever I try to copy files (usually larger files from > 250MB) to my Synology NAS, Finder temporarily freezes for about 10 seconds and sometimes locks up till the whole file is copied. The file then copies and all is OK.

I am using SAMBA (smb2 which has all support enabled on the NAS and has replaced AFP since Mavericks). Is there a way I can avoid this freeze. The file copy process itself is not slow but I can't use Finder to perform other operations. Many thanks in advance

  • One question: are you connected via WiFi or via an Ethernet wire? If you were via WiFi, try to use a wired connection to see if you have the same behaviour or not. – Huygens Nov 20 '13 at 7:44
  • Hi it is wired. WiFi is even worse and takes a much longer time to copy. I understand there is a bottleneck in case of WiFi (not the best router I got from the ISP I must admit) but in case of a wired connection I don't expect this to happen. – pechar Nov 21 '13 at 8:30
  • Alright, I will start an answer to detail you steps to investigate at least the problem. – Huygens Nov 22 '13 at 14:40
2

First of all, let's try to verify that OS X is using SMB2 for your shared drive.

Can you connect via Finder to your NAS share drive? Then open a Terminal (type terminal in Launchpad) and execute the command mount without any parameters, like this:

mount

This should output you several lines, one of which should be about your shared drive and how OS X is opening it (using SMB, AFP, NFS, etc.). Can you confirm that OS X is mounting it as SMB (or SMB2 if it shows that level of information)?

This is to confirm which protocol is effectively used.

Once the protocol is confirmed, try via the command line to copy a file > 250 MB. For this use the command rsync to show the progress, here is an example assuming you have in your home directory a big file named big_file.ext and the shared drive on your NAS is called share:

rsync --progress big_file.ext /Volumes/share

Do you have the same behaviour? Can you describe it better now?

Finally, it seems you are not alone and people are proposing workarounds while Apple is preparing (hopefully) a fix: https://discussions.apple.com/thread/5467191

In addition, try updating your Synology OS to the latest version. DSM 4.3-3810 has the following changelog entry: "Enhanced the compatibility of SMB 2 with Mac OS X 10.9"

  • Hi @Huygens, thanks for your quick reply and apologies for my late reply. I tried the above. The mount result is: //admin@192.168.1.83/Video on /Volumes/Video (smbfs, nodev, nosuid, mounted by [myusername]). I have the latest Synology update already. I tried copying the same file both with rsync and through UI. rsync takes circa 30 seconds (no hangs), with the UI the copy is faster but again hangs the Finder. What do you think? – pechar Nov 28 '13 at 8:47
  • If rsync is slightly slower than the "hanged" Finder, then the copy works fine from Apple's OS X, but it seems that the finder is buggy showing how it updates. Did you experience other hang like that one when copying from one Mac to another via network? (I'm asking the question because I have the feeling that Synology is not at fault here) – Huygens Dec 1 '13 at 11:12
  • Hi @Huygens I've tested a copy to another device (a windows machine) on the network with the same result i.e. a hang, unfortunately I do not have another mac so I cannot test that. What else could it be? This happened to me before I had Mavericks as well so it must be an issue with Finder unless the protocols are playing bad. – pechar Dec 5 '13 at 23:41
  • 1
    @pechar OK so we have to concentrate on OS X to find a solution. Could you try to perform a test transfer in the following 2 conditions: read the steps from discussions.apple.com/message/21236125#21236125 (message from Linc Davis) – Huygens Dec 9 '13 at 21:00
  • Hi @Huygens! I've done as directed in the link. The guest account was better but still hangs. The safe mode worked well. I suspected it was some third-party software. However after restarting from safe mode copying now works without any hangs. This morning before testing I updated to 10.9.1 so I believe that might have sorted it. I've checked the change log but nothing related to finder nor samba is mentioned. I guess I'll never find out :( – pechar Dec 18 '13 at 8:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .