Inside my early 2008 MBP (15", C2D 2.4, 4GB, GF8600M) I installed a used Samsung SSD (128GB), did a clean Mavericks install and at first startup, I restored the Applications, Desktop, Documents etc. from my Time Machine - it went fine. But now it boots up for 5 minutes, even though it used to take like 2-3 mins maximum when the original 200GB HDD with Mountain Lion was inside.

So I mirrored that new Mavericks SSD to the old HDD and booted the machine from it - time varies a lot. I tried different methods - a plain shutdown + start, a restart; I also switched disks couple of times - cannot see any relation to the boot time. In a series of bootups I measured times.

Booting from pressing the button to the login screen usually takes now (+-2 seconds):

  • from SSD 5:07 - that happened ten times.
  • from SSD it ONCE booted in 0:24 (+0:20 after logging in),
  • from HDD 0:49, 6:04, 5:35, 1:48, 5:44, 4:29, 5:45 (plus 0:40 to 1:10 after logging in) - this seemingly varies.

The bottom line is: booting from SSD usually takes exactly 5:07, though it once was 0:24. Booting time from HDD is unpredictable to me. On SSD, after logging in, it takes another 0:20 for all the apps in the background to start etc.; it's 0:40-1:10 on HDD for that - might not matter, but shows that SSD is is fact quicker once the system started.

Console application shows logs like this:

  • 15/11/13 16:54:28,000 bootlog[0]: BOOT_TIME 1384494868 0
  • 15/11/13 16:59:21,000 syslogd[19]: Configuration Notice: ASL Module
    "com.apple.appstore" claims selected messages. Those messages may not appear in standard system log files or in the ASL database.

so with every restart, there's boot time logged and the next message is >5 mins later (while using SSD).

Any hints on what to do next? What log to check? What can cause such long start?

UPDATE: When I run it in verbose mode, it always boots in 20s from SSD. It's 5:07 again when I don't hold cmd+v during startup. Fcsk tool says disk's fine. Any ideas?

  • I'm having a very similar issue. Boot often takes 5-6 minutes with Mavericks running on the latest 15 inch MBP with 1 TB SSD from Apple (no third party hardware at all.) – user77203 May 2 '14 at 0:26
  • I run my 17" MBP on stripe RAIDed SSDs, non-apple parts. I boot in about 9-12 seconds it seems. I'm unsure about your problem but I'd start by asking if your have TRIM enabled? I wonder if your SSD's in bad shape or if your OS image is just goofed up. I'm also no longer booting Mavericks, but rather Yosemite. – James T Snell Sep 3 '14 at 22:31
  • Have you selected the drive on System Preferences > Startup Disk? Something in Mavericks makes this setting not choosing the only automatically. – Víctor López García Aug 14 '15 at 22:38

Start in verbose mode and see what takes time. Here is how:

  1. Shut down your Mac if it is on.
  2. Press the power button to start the computer.
  3. Immediately press and hold the Command key and one of the following: ... the "v" key for verbose mode. (Command-V) You have successfully entered single-user or verbose mode when you see white text appear on the screen.

If it is "fsck", than you should start backing up your data – disk is most likely is failing.

  • Thx. Looks like booting up in verbose mode takes ~0:20. At some point during startup it mentions fcsk, but with no drama I guess. I run that tool anyway in single user mode - after couple of seconds it gave me "The volume SSD appears to be OK." The next regular reboot took 5:07. The next reboot in verbose mode - ~0:20 again. Any point in further search for the disk's glitches? Any tools, ideas? – user2785626 Nov 19 '13 at 7:46
  • 1. Is there any other place where it wais? Sometimes "Waiting for DSMOS" takes time. 2. Try reparing permissions. 3. Try installing AppleJack and check your preferences/clear caches, etc. – Dmitry Dulepov Nov 21 '13 at 12:50
  1. Take a look at the OS X Activity Monitor (it's in Applications/Utilities)

Do you see a process called installer?

  1. Go to /Library/LaunchAgents/ Do you see file names like?

com.genieo.completer.update.plist or /Library/LaunchAgents/com.genieo.engine.plist /Library/LaunchAgents/com.genieoinnovation.macextension.plist /Library/LaunchDaemons/com.genieoinnovation.macextension.client.plist

3) If so, you've installed the Genio spyware/fraud root kit.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.