1

I have a mostly dead internal hard drive in my '07 iMac. I've switched the machine over to an external FW800 drive but every now and then, on reboot, the mostly dead internal drive will mount on boot and it's mostly dead status causes no end of trouble on the machine. My Spotlight indexing chokes up trying to read it, LaunchBar complains and slows down, Disk Utility won't launch -- it's not good having it active.

I can't unmount the drive it's so close to dead:

iansimac:~ root# diskutil unmount /dev/disk0s2
Volume Main  on disk0s2 timed out while waiting to unmount

I'd like to put an fstab entry together to stop it from mounting once and for all, but I can't the UUID for the drive. The diskutil call against it hangs up at:

iansimac:~ root# diskutil info /dev/disk0s2
   Device Identifier:        disk0s2
   Device Node:              /dev/disk0s2
   Part of Whole:            disk0
   Device / Media Name:      Main

   Volume Name:              Main
   Escaped with Unicode:     Main%FF%FE%20%00

   Mounted:                  Yes
   Mount Point:              /Volumes/Main
   Escaped with Unicode:     /Volumes/Main%FF%FE%20%00

   File System Personality:  Journaled HFS+
   Type (Bundle):            hfs
   Name (User Visible):      Mac OS Extended (Journaled)
   Journal:                  Journal size 81920 KB at offset 0x1d18000
   Owners:                   Enabled

   Partition Type:           Apple_HFS

It'll eventually time out, but it takes a long time to get there. I can't format the drive or wipe it, those actions fail. As does trying to repair it. It's just not worth the surgery on a late 2007 iMac to remove it and replace it so I'd like to leave it in place, but take it out of the way.

Is there some other way to get the UUID for the device that doesn't involve using the disk in anyway? Would it be cached in a file some place I could take a look at? I've looked at the output from diskutil and couldn't see a way to get it without involving the device. And the mount output doesn't say anything about UUIDs in its output.

4
  • 1
    Know it does not answer your direct question, but would it not be sensible to remove or at least disconnect the drive. Know I macs hard drives are quite difficult to get to. Check support article on ignoring internal drive. discussions.apple.com/thread/4187825 I would however still recommend you get it out. Do you really want an piece of broken hardware inside your computer? – Joop Nov 18 '13 at 8:52
  • 1
    PS. have a look at the replacement guides. I am not an expert but have done it few times and it is not as difficult. You might not even have to go all the way as you just need to gain enough access to remove to power cable to the drive. Only tricky thing is to stop dust from getting behind the glass. – Joop Nov 18 '13 at 8:56
  • I agree with Joop, if it's this much of a frustration I would at the very least disconnect the hard drive. Assuming it's an aluminum iMac you could simply remove the glass, unscrew and lift the bezel, disconnect the SATA data cable from just to the right of the RAM and reassemble. With that SATA cable disconnected your Mac should no longer see your hard drive at all. The process shouldn't take longer than 15-20 minutes. Beyond that I don't know of a way to find the UUID without accessing the disk. – Mr Rabbit Nov 18 '13 at 12:47
  • I'm not interested in pouring the time or energy in to this old machine to remove or replace the drive. – Ian C. Nov 18 '13 at 16:23
2

Have you tried looking at the kernel log messages? If, as you said earlier, it tried to root from the drive at least once, you can try to find it in the /var/log/system.log, for example:

$ grep 'rooting\ via' /var/log/system.log
Oct 24 18:01:44 localhost kernel[0]: rooting via boot-uuid from /chosen: 4AB3D289-884F-379C-AF7B-************
Oct 25 11:21:57 localhost kernel[0]: rooting via boot-uuid from /chosen: 4AB3D289-884F-379C-AF7B-************
Oct 28 10:30:54 localhost kernel[0]: rooting via boot-uuid from /chosen: 4AB3D289-884F-379C-AF7B-************
...

Those logs are usually kept for months, so you should be able to get it.

2
  • My /var/log/system.log file only goes back to November 19th, which isn't far enough back to catch this drive as the boot drive. There are other UUIDs in it, but none for the dead drive. But that was a great idea, up vote for that! – Ian C. Nov 20 '13 at 5:41
  • I managed to get the UUID from diskutil tonight but this was a great idea so it gets my mark for the answer to the question. – Ian C. Nov 20 '13 at 6:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .