6

I can get to my FTP server just fine from the command line but I cannot get to it from Finder. When I am in Finder and I "Connect to Server" and enter ftp://192.168.125.128/, then my credentials when prompted, it gives me the error:

There was a problem connecting to the server "192.168.125.128".
The share does not exist on the server. Please check the share name, and then try again.

I can however connect to it anonymously just fine, which is frustrating, because as stated before, I am able to log in just fine and browse around from the command line using my credentials.

ftp 192.168.125.128
Connected to 192.168.125.128.
220 (vsFTPd 2.3.5)
Name (192.168.125.128:name): 
331 Please specify the password.
Password: 
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
229 Entering Extended Passive Mode (|||26727|).
150 Here comes the directory listing.
drwxrwxr-x    3 1000     1000         4096 Dec 12 14:38 yadayada

Is there something else I need to do with Finder?

migrated from stackoverflow.com Nov 18 '13 at 7:03

This question came from our site for professional and enthusiast programmers.

  • What about specifying the credentials in-line with the IP address, e.g. ftp://username:password@192.168.125.128? – Darth Continent Jan 2 '13 at 19:11
  • It doesn't like that format. – Michael Jan 2 '13 at 19:22
18

I figured out the problem. I sniffed the traffic from my computer to the FTP server and saw traffic go through when I connected as a guest. I did not, however, see any traffic when I connected as myself. No traffic whatsoever was going through. On a whim, I tried a blank password and saw traffic going through! After changing my password on the FTP server I was successfully able to connect with Finder. It apparently had something to do with my password??? I played around to see what the exact problem was with my password and, at the risk of revealing too much information about my security credentials, found that any password with an '@' symbol in it caused Finder to immediately display that error and not even try to send any traffic to the FTP server.

  • 2
    I also had an @ in my password. After hours of frustration you saved my day, sir! Thanks alot! =) – Dafen Nov 5 '13 at 11:31
  • 1
    udrWFmSXTgIXGdQ/URJABZvOLiL5GIfj failed for me. I then generated a password without a '/' and it worked. – Keith John Hutchison Aug 27 '18 at 7:20
1

This seems to also impact cPanel FTP user accounts which mandate the addition of the domain name after the username (e.g. username@domain.com). This is particularly true for hosting sites like GoDaddy and others who have moved to cPanel on the Linux hosting accounts.

1

You need to be sure your path ends with forward slash '/'

ftp://username:password@ftp.your.domain.com/
1

Use username+domain instead username@domain

Example:

ftp://username+domain.com:password@domain.com

-2

The solution to the cpanel problem that mandate an @ in the username (i.e. user@domain) is to use a separate ftp program like "FileZilla" which has a version for mac.

  • Not good form to piggy-back on an answer. Answers should be complete so that if your answer is voted up/marked as the best answer it will be comprehensive. Thanks for contributing. – willWorkForCookies Oct 8 '15 at 13:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .