1

Very curious problem - only Chrome can access the Internet, but literally everything else cannot. Confirmed this in Activity Monitor's Network tab (it shows 0 bytes sent/received for literally every process other than Chrome). Mail, Software Update, Safari, App Store, all can't connect. At first I suspected it was a botched uninstall of Little Snitch or K9 internet filter, but now I'm suspecting something deeper in the system. Cleared DNS cache and other items using Onyx. Still no luck. Thanks in advance.

  • 1
    Sounds like a DNS issue. Can you verify Chrome is using the same DNS as everything else? – user13716 Oct 27 '14 at 3:04
1

Are you able to get access out using command line programs? For example, can you ping google.com or perhaps ping 74.125.226.226? Ping will communicate using the ICMP protocol. So knowing whether or not requests on ICMP can communicate out may help to solve this mystery.

As far as whether or not you can communicate on TCP, you should try curl google.com and/or curl 74.125.226.226. Whichever works. The google.com one should produce some short HTML code, in which you can see "301 Moved". The 74.125.226.226 one should produce a lot of code. This is what Google's standard search page is. If neither work, something's perhaps blocking any TCP request not made by Google Chrome. Which is really strange. If one, the other, or both work however, we may be looking at more of a blacklisting situation. Hard to tell though. If it fails though, tell me what it says when it fails. It may be a standard "couldn't connect to host" or it may be something more helpful.

One more thing you can do is check Activity Monitor for any possible processes leftover from Little Snitch or K9. Only Little Snitch can block programs, I'm guessing though because from a quick glance at K9's site, they didn't say anything about blocking programs. So you really want to look for anything that might be associated with Little Snitch.

That's all I can think of for now. Let me know the results and hopefully I can help you more.

  • 1
    Aha! Thanks for the ideas! Curl and Ping to IP address worked, domain name could not resolve. Turned out the culprit was mDNSResponder (not being loaded it seems). Thanks for the ideas! – Geek at Heart Nov 19 '13 at 1:38
  • I have had this exact same thing happen on a 10.6.x machine also with Chrome being the only thing to get out on the internet and the same ping results. The only way I found getting it working apart from a reboot was to unplug the ethernet cable for a few seconds and plug it back in. Thanks for the heads up on mDNSResponder we knew it looked like something to do with DNS but could not pin point it. Still its is odd that Chrome could get out? – markhunte Jun 2 '14 at 6:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .