7

I set theme in .zshrc file:

ZSH_THEME="random"

And when open new tab, it shows that new theme is loaded:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/gozilla.zsh-theme' loaded...
mac

But in fact I dont see any changes in theme.

New tab again

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/crunch.zsh-theme' loaded

and again:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/tjkirch.zsh-theme' loaded...

But still see the same theme. I have already reloaded mac, but no result. The same result in Terminal and iTerm

Update:

Not all themes fails. This one works: trapd00r but with error: prompt_jnrowe_precmd:3: command not found: zsh_path. Others not working.

Update 2: linuxonly theme works too:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/linuxonly.zsh-theme' loaded...
mac
maks@Makss-Mac:s047->/Users/maks (0)

but with error:

Can't open perl script "/home/scp1/bin/foopath": No such file or directory
  • No it dont work if I choose theme manually – Maxim Yefremov Nov 17 '13 at 12:14
6
+50

Do you have a custom PS1 that is overriding the prompt from the theme you have selected?

  1. Check you don't have any additional lines in ~/.zshrc beyond the default?

    1. Backup your .zshrc
    2. Delete all lines beyond export PATH=$PATH:/
    3. Reload your Terminal
  2. Do you have any plugins that are messing with things?

    • Check ~/.oh-my-zsh/custom/plugins/ for any additional plugins.
    • Remove all your plugins from your ~/.zshrc and reload your Terminal.
  3. Check you don't have any additional lines in your ~/.zprofile?

    mv ~/.zprofile ~/.zprofile-bak
    

    …and reload your Terminal. (Put back with mv ~/.zprofile-bak ~/.zprofile)

Note: trapd00r and linuxonly show the same errors for me

  • I Deleted all lines beyond line export PATH=$PATH:/ and themes started to work. – Maxim Yefremov Dec 3 '13 at 3:24
4

Do you have your iTerm profile set to report 256 colors?

enter image description here

  • Report Terminal Type was xterm, now xterm-256color. But theme still is not working. – Maxim Yefremov Nov 18 '13 at 5:40
  • +1 to counter undeserved no-comment downvote - this is a viable reason why the themes may not appear to work for some people. – grg Dec 5 '13 at 22:35
  • 1
    I don't use iTerm, I use the normal Terminal app. But this fixed it for me: Terminal (menu, top left) > Preferences > Profiles (tab) > (gear icon bottom left) > Restore Default Profiles – Preston Badeer Oct 23 '15 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .