0

I have some difficulties understanding what's wrong in Automator:

I used to launch a short automator script with an exiftool command to organize my pictures by folders:

exiftool -v '-Directory < DateTimeOriginal' -d /Users/home/Pictures/Photos-Sources/APN/%Y/%Y-%m" "%B/%Y-%m-%d" "%A -r "$f"

This script created a folder named according to the date the photo was taken. In my case, some arguments (month or day) are in "French literary", due to my OS X configuration (exiftool doesn't come with any localization option).

After Mavericks installation, the script is still working, but these same arguments are in English only; even when I use this script in a Terminal, they still come in French.

Does anyone have the same issue, or anyone else could help me to understand if I'm mistaken somewhere?

1

You can change the time format by setting LC_TIME to fr_FR:

LC_TIME=fr_FR exiftool -v '-Directory<DateTimeOriginal' -d ~/Pictures/Photos-Sources/APN/%Y/%Y-%m\ %B/%Y-%m-%d\ %A -r "$f"

$ LC_TIME=C date +%A\ %B
Monday November
$ LC_TIME=fr_FR date +%A\ %B
Lundi novembre

Terminal and iTerm 2 set LANG (which changes LC_TIME) automatically based on the region selected in System Preferences.

On my installations of 10.8 and 10.9, the Run Shell Script command uses the C locale by default though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .