2

Last night I upgraded from Mountain Lion to Mavericks (mid 2009 macbook pro). Everything went smoothly during the upgrade, but it resulted in an extremely long and unstable boot process. If I was lucky the Mavericks volume would boot after quite a while waiting at the gray apple screen. However, I frequently would not make it through the login process without it seizing up and requiring a hard restart. If I did manage to get logged in it would similarly crash within a short period of time (roughly anywhere from 5-15 minutes). I'm not sure what was happening exactly (kernel panick?), but it would rapidly go from normal operation to spinning beach ball to completely frozen, never to recover on its own.

I should add that a few months ago I spilled a drink on my keyboard. It was pineapple juice, not too much but obviously enough to cause problems. I took the laptop apart and as much of the keyboard assembly as possible, and thoroughly cleaned it with 99.99% isopropyl alcohol. Unfortunately several keys are still shorted or otherwise damaged, so I've been using a USB keyboard since then. Not sure if this h as a hand in my current problems but it seems relevant. I did try disconnecting the keyboard/power ribbon from the logic board to see if it changed anything. I jumped the power pads and it powered on but the boot problems were the same.

Before that I tried booting into recovery and repairing the disk. It did find and repair some errors but that didn't resolve my issues. I booted to an old Snow Leopard install dvd and went through the disk utility operations with that to the same end. Next, still using the DVD, I shrank my Mavericks partition, created a new one with the free space, and installed Snow Leopard on that. It installed fine, rebooted into snow leopard, configured itself, rebooted again, and I haven't been able to get past the grey apple loading screen since.

I can't boot in to safe mode with shift, nor into the volume manager with option. I can't boot into the Mavericks recovery drive, I assume because currently the Snow Leopard partition is the startup disk. I can boot into single user mode, I run fsck -fy, it finds and corrects an error. I run it again, and it says the volume appears to be ok. I reboot, and am once again stuck at the grey apple with the spinning gear. Additionally, I haven't been able to boot the Snow Leopard DVD since the install, holding C during startup does nothing.

So the short of it is, currently I can't boot into anything but single user mode, and I'm not sure what else to try. Any help would be greatly appreciated.

Update: I successfully set the startup disk back to the mavericks volume with bless, but I'm still having the same issued. I ran fsck -fy until there were no reported changes, but it hasn't changed anything.

  • It seems you have a hard-disk failure. Try booting on an external drive. If it works you should consider replacing your internal hard-drive. However, even this is not guaranteed to work: the problem can also come from the eSATA cable that links the drive to the motherboard. – Frizlab Nov 17 '13 at 10:37

You must log in to answer this question.

Browse other questions tagged .