22

Whenever I try to use the dictation feature in OSX, it mutes my sound. I want to hear the audio I'm playing in iTunes or somewhere else while I have dictation enabled. How can I do that?

5
  • 3
    I had completely the opposite reaction to this feature - so useful :)
    – grg
    Nov 16, 2013 at 21:27
  • I have some really bad audio of speech and I want to "transcribe" it using my own voice and dictation. In other words, I want to listen to the audio and repeat the words in it clearly while dictation types it out for me.
    – user13716
    Nov 16, 2013 at 21:29
  • Does this also happen when you have headphones connected? Or just when sound playback is through the loudspeakers?
    – Hobbes
    Nov 19, 2013 at 9:49
  • I only know it happens when my headphones are connected.
    – user13716
    Nov 20, 2013 at 23:19
  • with iTunes, Dictation only pauses the sound, and continues wherefrom it left, while other players are just muted and are playing in background, which is meaningless. but the way Dictation works with itunes is very meaningful: the idea is to use it to transcribe what you hear, and dictating is for most people possible only when the sound they hear is paused
    – user61618
    Mar 19, 2014 at 12:03

4 Answers 4

12

You need to set some hidden preferences to make this work (OS X 10.9 - Mavericks). Open Terminal and enter the two commands below:

defaults write com.apple.SpeechRecognitionCore AllowAudioDucking -bool NO
defaults write com.apple.speech.recognition.AppleSpeechRecognition.prefs DictationIMAllowAudioDucking -bool NO

After doing this turn off dictation in Systems Preferences, wait a few seconds and then re-enable it. You should now be able to dictate while audio is playing. I’ve only tried this while using a headset/headphones, it’s probably not advisable without. :)

To restore your system to it’s virginal state, run these commands in Terminal and then restart dictation:

defaults delete com.apple.SpeechRecognitionCore AllowAudioDucking
defaults delete com.apple.speech.recognition.AppleSpeechRecognition.prefs DictationIMAllowAudioDucking

Found via: https://gist.github.com/rmangino/8388849

2
  • 1
    Works on macOS Mojave 10.14.1! Dec 9, 2018 at 20:39
  • Doesn't seem to work on Catalina 10.15.7. :-\ Apr 9, 2021 at 15:56
3

This preference was made visible in System Preferences, so you don't need to run Terminal commands any more. Go to the Accessibility preference pane, choose Dictation and disable Mute audio output while dictating.

1
  • 5
    Unfortunately I can no longer find these Dictation Accessibility settings in MacOS Catalina.
    – P A N
    Mar 6, 2020 at 14:20
1

The program Audio Hijack Pro can handle this.

Add system audio on right, then press hijack 1st and mute 2nd.

1

It's possible to use Voice Control's voice dictation while listening to something on YouTube. At first it wasn't working on Google Chrome but I had to restart the app and now it's working.

The only weird thing is this voice dictation never really stopped so there is never a click sound that says voices dictation is over. Even though I clicked it on so maybe have to restart my whole system but as it stands this is what it does and it looks OK.

I also might mention that it disables it is the dictation button so that's kind of weird and even though I am using AirPods Pro it seems like it's not as tight of a voice dictation accuracy as the original voice dictation.

Accessibility preference pane

You must log in to answer this question.