9

Since the update to Mavericks, my MacBook has stopped going to sleep when I close the lid. I did some investigation and found out a command (pmset -g) to identify the process(es) that prevent it from sleeping.

The output:

$ pmset -g
Active Profiles:
Battery Power       -1
AC Power        -1*
Currently in use:
 womp                 1
 halfdim              1
 sms                  0
 hibernatefile        /var/vm/sleepimage
 gpuswitch            2
 networkoversleep     0
 disksleep            0
 sleep                0 (sleep prevented by AddressBookSour)
 hibernatemode        0
 ttyskeepawake        1
 displaysleep         15
 acwake               0
 lidwake              1

As you can see, AddressBookSour, short for the process Address Book Source Sync, is preventing the computer from sleeping. Unfortunately I can't quit this process, because it's a daemon and soon after I kill it, it starts again. I tried deactivating the synchronisation of my Google Contacts from the Address Book (I don't use iCloud) but it didn't help: the process is still running and preventing the sleep.

2

With the addressbook preventing the sleep I used the following procedure to fix it on my MBA 10.9.2

As always it is recommended to Back up all data.

Triple-click anywhere in the line of text below on this page to select it:

~/Library/Caches/com.apple.AddressBookSourceSync

Right-click or control-click the highlighted line and select

Services ▹ Reveal

from the contextual menu.* A folder should open with an item selected. Move the selected item to the Trash.

Log out, log back in, and test. If there's no change, go to the next step.

*If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select

Go ▹ Go to Folder...

from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

Step 2

If you use iCloud, uncheck the box marked Contacts in the iCloud preference pane. Press return to confirm, or click Keep on Mac in the dialog that opens.

Step 3

From the list of groups on the left side of the Contacts window, select All On My Mac. If that group doesn't exist or is empty, skip this step. Otherwise, from the menu bar, select

File ▹ Export ▹ Export vCard

Save the exported contacts to the Desktop.

Step 4

Quit Contacts. Reveal the following item in the Finder as you did in Step 1:

~/Library/Application Support/AddressBook Move the selected folder to the Desktop, leaving the window open for now.

Step 5

Launch Contacts. Your contacts will be gone. If you took Step 3, then double-click the file you created in that step and confirm that you want to import from it. Your contacts will reappear.

Step 6

If you took Step 2, reverse it. Test. If the issue is resolved, delete the AddressBook folder and the vCard file on the Desktop and close the open folder window.

Otherwise, quit Contacts again and put the AddressBook folder back where it was, overwriting the newer one that will have been created in its place.

Courtesy. https://discussions.apple.com/people/Linc%20Davis

0

I had a similar problem before. I used this article - Advanced troubleshooting for contact and calendar syncing - as a reference for fixing a broken Contact Sync.

Try the methods described there, and it all goes well you should Mac should sleep like a baby.

Note: there's a specific method for disabling contact sync from there - so maybe you should try that first. Try it and see if it works.

AB

  • 1
    If you read the article, the last line reads: "You are not using OS X Mavericks v10.9 or later. This article does not apply if you are using OS X Mavericks." The complaint stems from Mavericks. This is an inherent issue with Mavericks that Apple is aware of but has no solution. – user77330 May 3 '14 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .