I have a folder on a HFS+ volume I can't delete. I already tried to get rid of the ACLs but somehow this doesn't worked out.

The folder is calles CrashPlan.app.

Here is what the terminal says:

    sh-3.2# ls -ahel@
    total 0
    drwxrwxr-x@ 3 root  admin   102B 23 Okt 22:58 .
        com.apple.backupdelta.MoveChecked      3B 
        com.apple.s stem.Security     68B 
    drwxr-xr-x@ 3 root  wheel   102B 30 Okt 13:21 ..
        com.apple.backupd.SnapshotVolumeFSEventStoreUUID      36B 
        com.apple.backupd.SnapshotVolumeLastFSEventID     20B 
        com.apple.backupd.SnapshotVolumeUUID      36B 
    drwxrwxr-x  2 jan   staff    68B 13 Nov  2012 CrashPlan.app

    sh-3.2# cd CrashPlan.app/
    sh-3.2# ls -ahel@
    total 0
    drwxrwxr-x  2 jan   staff    68B 13 Nov  2012 .
    drwxrwxr-x@ 3 root  admin   102B 23 Okt 22:58 ..
        com.apple.backupdelta.MoveChecked      3B 
        com.apple.s stem.Security     68B 

Strange thing here is, if you look from the outer folder there are no ACL for the folder. But if you look from the inside there are.

How can that be and how I can get rid of it?

  • FWIW, I also have com.apple.s stem.Security in four files (actually directories), 44 bytes in size, on my SSD. In a previous dump of names and attributes, I had some files in /.MobileBackups that also had it, but some of those had 68-byte size; the 44-byte ones were mirrors of the above-mentioned, and the 68-byte ones were others. I bought the SSD in February of 2014 and have only formatted once. I'm not sure if those files came from my old drive with that attribute, or if it arose after that. Commented Feb 2, 2016 at 4:28

2 Answers 2


The CrashPlan.app does not have an ACL. The output of ls is consistent, you must have misread it.

  • When you run ls -a in the parent directory, it tells you that . (i.e. the parent of CrashPlan.app) has extended attributes, and that CrashPlan.app has no ACL (mode string rwxrwxr-x).
  • When you run ls -a inside CrashPlan.app, it tells you that . (i.e. the CrashPlan.app directory) has no ACL (mode string rwxrwxr-x), and that .. (i.e. the parent directory) has extended attributes.

The parent directory does not have an ACL, but it has extended attributes com.apple.backupdelta.MoveChecked and com.apple.s stem.Security. This second attribute is odd: it should be com.apple.system.Security. This is a sign that your filesystem may be corrupted.


I had what appeared to be the EXACT same problem. The issue was with the system immutable flag on CrashPlan.app in my .MobileBackups folder.

Actually, it was an old .MobileBackups folder from a Previous System folder that was created during an "Archive and Install" of OS X, so I knew it was nothing I needed. It was completely inactive, but I couldn't delete it no matter what I tried.

This is what finally did it for me:

sudo find TopLevelFolder/ -flags +schg -exec chflags noschg {} \;

Where TopLevelFolder is the folder containing (all of?) the offending CrashPlan.app folders. This removes the system immutable attribute which makes it possible to now delete the files.

As always, be very careful with rm -rf, but running the following command next will then remove the files.

sudo rm -rf TopLevelFolder

Where, again, TopLevelFolder is the same as the one above. I hope that helps someone else.

You must log in to answer this question.