1

I noticed that cvs was removed from Mavericks. I replaced it via MacPorts, but I find that cvs co [projname] with a correct $CVSROOT and cvs -d acct@server://path-to-cvs-repository co proj_name also fails with a "server: Connection refused" message.

Clearly, I'm using ssh to connect and sync, and I know there are two types of keys that cvs supports and I wonder if I'm sending the wrong key type.

My server is a FreeBSD system on 9.2 and I may not have attempted a checkout or import since I updated from 9.1.

Before I dove into man pages, I was wondering if any one else has found and solved this problem?

--EDIT December 3, 2013

Installing cvs via fink solved my problem. fink also installs an openssl dependency and my casual conclusion is that is the key. After testing /sw/bin/fink, I uninstalled my MacPorts cvs so there'd be only one available on my $PATH.

1

It sounds like a Problem with the CVS Server config.

You should probably take a look at the config file.

CVSROOT/config

Also it would help you if take a look at the cvs logfile on the server maybe there is something logged why your connection has been refused.

I use the cvs cli tool from homebrew and it works with no Problems. CVS under Mavericks still works.

1
  • Thank you for your response. As this was an 11 year old repository, I was skeptical that the config file was a problem. I checked and saw nothing that was problematic. I did try cvs from a 1st-gen MBA that was running Lion and it worked. Then I installed cvs via fink (which also installs an openssl dependency) onto a Mavericks system and that worked well. (I am leaning towards there being an issue with MacPorts' cvs using Mavericks' openssl). So, I'm good now. – dannyo Dec 3 '13 at 15:51
1

Even though the reported issue is old. I am writing the answer as I done feel moving away from macport is a solution instead changing what cvs command is using for connection is.

I faced the same issue recently when I installed the CVS with macports. On further debugging of cvs command revealed that rsh connection is being used in macport cvs instead of required ssh, to resolve this issue without moving to fink, I just added the below lines to the ~/.bash_rc profile of my user, and opened a new terminal to load updated bash profile. This actually solved my issue.

CVS_RSH=/usr/bin/ssh
export CVS_RSH

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .