2

I'm new to Macs and got a 2011 MacBook Pro a few weeks ago and when I first set it up there was an American Flag on my menu bar. Somehow it has disappeared and I can't figure out how to get it back.

enter image description here

10

in the Language and Text, under Input source, you need to select one or more input sources; you also need to select Keyboard and Character Viewer on the top of the input source list.
As far as I know, the flag is displayed only when you select more than one input source; differently, the icon you see is a generic one.

This is the icon you see when just an input source is selected.

Generic icon

This is the icon you see when you selected two or more input sources; in this case, the selected input source is "Italian Pro."

"Italian PRO" icon

  • Thank you. So it really like a menu that lets you switch between the two input languages. – Chris_O Mar 30 '11 at 14:23
0

You have to go to your system preferences and go to language and religion or language and text. When you get there you will see a small button in the bottom that says keyboard preferences, when you get there you can choose your languages and you will have the small flag.

  • 1
    This answer is incomplete. It also appears to be written for macOS Sierra and not the system the OP was using in 2011. In Sierra, you also have to check the box Show input menu in menu bar to display the flag but this isn't in your answer. See How to Answer on how to provide a quality answer. - From Review. – fsb May 7 '17 at 14:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.