1

When Mavericks came out I've (as many others) installed the update. But something went wrong. First of all update didn't finish properly. It stayed on the last step in "less than 1 minute left" state for multiple hours, then screen became black and I rebooted my Mac Mini. System rebooted and loaded without problems, so I've decided that it was some unimportant glitch. But now my system misbehave in different ways and is pretty much unusable.

  • When my screen sleeps and I awake it, nearly every time some windows are broken: they jump to top left corner, become very small (something like quarter of screen) and are unresizable and unmovable. Every time I try to move them they jump again to their beloved place in the corner and refuse to go from there. I need to quit from broken application and start it again. Also changing screen resolution back and forth helps.
  • Sometimes after awakening the screen I see the same black screen as in Mavericks installation and need to reboot Mac.
  • Sharing my folder by SMB to my Android devices stopped working (ok, this should be because of SMB update in Mavericks, so it's more of a feature than a bug)

I believe this is the most frustrating OS experience which I had for a long long time. Including different versions of Windows, different Linux distros and even Android MiniPC.

So the question is -- is there any way I can reinstall Mavericks update without losing (and backing up) all my data and applications? I know there is always an option to format HDD and make clean install, but I would prefer a less radical way if it is possible.

1

Ok, answer for the question was pretty much obvious -- you just go to the AppStore and hit 'Download' on Mavericks once again. It then asks if you really want to reapply the once downloaded update. Just accept it and update will be reinstalled.

If you want to reuse once downloaded update file you could use advice from this question.

But the main problem (with jumping windows) wasn't resolved. To resolve it I used advice from this thread on apple.com. I've rebooted to safe mode and then rebooted once again to normal mode. After that the issue was gone. At least till now. Hope this helps to someone.

  • I could have answered this like 2 weeks ago, I did not know this post existed. I've installed Mavericks the way you describe in your answer, assuming everything would be gone - it wasn't. – Rob Mar 4 '14 at 13:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .