1

I am running the built-in apache server on an iMac to serve my personal website, just some static page. I have been using this machine for a couple of years. I just start it with

sudo apachectl start

But, after the upgrade to 10.9 a problem has surfaced (I'm not sure if these are related). Sometimes the httpd daemon stops answering requests. That is, I try to telnet mymachine 80 and it just hangs there.

But, I still can ssh my machine and that works. Immediately after I connect via ssh the httpd daemon starts responding. So, I am guessing it was sleeping? But then, right after I disconnect from ssh the httpd also stops responding (sometimes, other times it runs fine).

I have already checked under System Preferences → Energy Saver. I have it set to Computer "Never go to sleep".

This is also true when using the $20 "OS X Server" app to run the web server.

0

I think the answer is "Stop pressing the Power Button".

I had read that tapping the power button in Mavericks would turn off the monitor. In fact this is wrong, it puts the machine to sleep.

It is a very light sleep because the machine will still respond to 'ssh' requests, and the moment one tries to ssh into the machine the httpd will magically wake up. But, if no one tries to ssh, the httpd daemon will stop responding a minute or so after one taps the power button.

I was sometimes tapping the power button to turn of the monitor. I have stopped doing that. So far so good.

More updates if this turns out to be the wrong answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .