I have a late 2011 MBP, running Mac OS X 10.7.5, 2.3 GHz Intel Core i5, with 16GB 1600 MHz DDR3.

When I reboot and I try to open a Finder window with command + n or from the menu

File > New Finder Window

I see the window open and then disappear somewhere off to the left or right off the screen.

If I open multiple windows the same thing happens.

When I invoke App Expose I can see all the Finder windows I opened but as soon as I close App Expose they disappear again.

I cannot drag or select the windows in any way.

When a second monitor is connected I tried dragging them onto the second monitor but that does not help either.

The only thing I found works is:

  1. Press: command + alt+esc ;
  2. Select Finder;
  3. Click Relaunch.

Normal behaviour resumes.

Is there any way to troubleshoot this behaviour and stop it?


This has just happened again, and this time I took a video.

When the finder windows appear in this video, that is when I am changing desktops with command+ right. As you can see I cannot get the finder windows to show up at all.

  • I think it is teething problems with Mavericks. I am getting this in more than one app. Not just finder.
    – markhunte
    Commented Nov 18, 2013 at 3:03
  • @markhunte I did specify that I am running Lion 10.7.5, not Mavericks on this box, in the intro to my question. I do have a Mavericks and Mountain Lion box and they don't display these issues. This is my work box and I don't want to upgrade, as it works perfectly apart from this little nagging thing. But it could be related, how are you thinking of troubleshooting?
    – Deesbek
    Commented Nov 18, 2013 at 3:15
  • So you did. I think it is something to do with the Assign to desktop option going haywire. But the only way I will be able to find out is looking for a patten.
    – markhunte
    Commented Nov 18, 2013 at 8:35
  • And just as I wrote that it just started happening in Applescript Editor
    – markhunte
    Commented Nov 18, 2013 at 8:37
  • Here is a link to a video showing the issue I am having which I think is the same a s yours markosx.com/blogR/stackoverflow/Question-110628/WindowBug.mov
    – markhunte
    Commented Nov 18, 2013 at 8:59

3 Answers 3


When I have a badly placed window I usually zoom it.
Finder Menu->Window->Zoom. Works for other programs as well. Not sure if that works for your case, but worth a try.

  • Thanks this may solve the issue, but does not answer why it happens in the first place. I will try it and see.
    – Deesbek
    Commented Nov 22, 2013 at 0:45
  • It just happened again, and zooming did not help. I have posted a video though.
    – Deesbek
    Commented Nov 24, 2013 at 2:21
  • I can only think of 3 things. - 1, remove the .plist file, as mentioned above by Ashley - 2, check disk permission in disk utilities - 3, create and migrate to a new account - 4, do a new clean installation Commented Nov 24, 2013 at 3:51
  • I have completed #1, no change. I am doing #2 now and will report, back. #3 and #4 defeat the purpose of my question, I can live with "Relaunching" Finder, however I would like to know what is causing the issue.
    – Deesbek
    Commented Nov 24, 2013 at 4:04
  • #2 there were issues with the permissions on system files. I ran the fixes, but no joy. Same issue when I reboot.
    – Deesbek
    Commented Nov 24, 2013 at 4:28

I'd try the following steps:

  1. First, check whether the issue applies to your entire Mac, or just your user account. To do this, create a second user account (System Preferences > Users & Groups), log in as that user, reboot and test.

  2. Assuming the issue appears only in your normal user account, try resetting the Finder's preferences in that account. To do this, in the Finder, open the Go menu, then hold the alt/option key and select the Library option that appears. Then look for the com.apple.Finder.plist file in the Preferences folder (not PreferencePanes). Drag that plist file to the Desktop (or somewhere else... basically, keep the original copy just in case). Then reboot. The Finder should create a fresh copy of that file, and I'm hoping this might resolve the issue.

  • Oki, so when this happened again (it does not happen after every reboot and sometimes happens right during a session) I logged into the second user, and there was no issue. I tried to delete the com.apple.Finder.plist file but it does not exist in /Library/Preferencesl I'll reboot and see if one is created, then do a search for it.
    – Deesbek
    Commented Nov 24, 2013 at 3:04
  • I found it in ~/Library/Preferences moved to desktop. Reboot. Some of my finder preferences changed (predictably) however I am still having the same issue after the reboot.
    – Deesbek
    Commented Nov 24, 2013 at 3:44
  • I'm sorry to hear that. I'm out of ideas, I'm afraid...
    – Ashley
    Commented Nov 25, 2013 at 12:00

I have tried both the solutions in the answers, and comments however the only thing I found works is:

  1. Press: command + alt+esc ;
  2. Select Finder;
  3. Click Relaunch.

Normal behaviour resumes.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .