5

When I plug headphones into output of MBP (15-inch Early 2008) with Mavericks - nothing changes, sound comes from internal speakers, nothing in System Preferences too. SMC reset, NVRAM cleared, sleep/wakeup - same situation:

enter image description here

UPDATE: Upgraded to 10.9.1 - no change

  • 3
    @grgarside Since Mavericks. No audio software. Works in Linux. Doesn't work with another account too. Reboots didn't help, even with headphones plugged in. – GioMac Nov 23 '13 at 13:05
  • When you say it works in Linux do you mean in a vm on the MBP or plugged into a different computer> which proves that it is not an issue with your headphones. If not a vm do you want to try Linux in a VirtualBox and see if your headphones work there? – Deesbek Nov 24 '13 at 3:29
  • 3
    @Deesbek I've got dual-boot on MBP :) – GioMac Nov 24 '13 at 18:59
  • Get a clean headphone jack, and basically lug it in and out of your socket lots, twist it, turn it, jiggle it - also have a good blow in there, then see if it behaves the same. Sounds to me like some of the socket poles are sticking. – stuffe Nov 27 '13 at 10:44
1

If you see red glowing light coming from it try the toothpick approach: take a toothpick and poke around in the jack until light turns off.

Source from: Apple inc

OS X Mavericks: Audio ports

  • 1
    Nope, optical output is off - no red light – GioMac Nov 26 '13 at 9:22
1

From https://discussions.apple.com/thread/5500054.
This appears to have worked for me so far. I'll update if it stops working.

Close all windows and quit all applications.

Click "Go" menu in the Finder menubar.

Select Computer, then Macintosh HD / Library / Preferences

Open "Audio" folder.

Right click these two files and select "Move to Trash".

  • com.apple.audio.DevicesSettings.plist
  • com.apple.audio.SystemSettings.plist

Close the window. Restart the computer.

  • 1
    no change - everything's same – GioMac Nov 26 '13 at 19:47
0

looks like your headphones jack has problem. Since its a hardware issue, better take it to apple store and get the jack replaced.

  • 2
    It's clearly not a hardware issue since GioMac stated it works when he boots into Linux on the same computer. It's a software issue with OS X 10.9 Mavericks only, as the issue only occurred since he has had 10.9 installed and it works on another OS on the same computer. – superriku11 Nov 26 '13 at 21:12
0

Funny, but despite the fact that headphones are working in linux properly - after replacing the small board with audio and power components - everything works fine on mac os x now :D

  • Hi, can you explain in more detail what you did? Did you open up the Mac and change the sound and power components on the motherboard? – Himanshu P Aug 24 '14 at 14:54
  • Yes, I've replaced the small board. – GioMac Aug 25 '14 at 10:14
0

I tried all of the above. What finally fixed the problem was resetting the PRAM. Reboot. After the screen goes black and before the apple logo appear, basically at the moment it starts coming back, hold down command-option-P-R. Continue holding through the boot sound until the screen blacks and the apple logo appears a second time.

That should do it.

  • didn't work for me – GioMac Nov 7 '14 at 11:44
0

Sounds like most of solutions people have put forward didn't work for OP. But for the sake of any one finding this question by google, and suffering from a similar problem that I just had here's how I fixed it.

The Cause

I had set up a few screen sharing programs which did some pretty annoying stuff to the audio drivers, which required me to specify whether I wanted audio to come out of the builtin speakers or headphone jack, even after uninstalling these programs the problem still persisted.

What Fixed this

I entered the following commands in my terminal, you'll be prompted for your password.

sudo rm /Library/Preferences/Audio/*.plist
sudo killall coreaudiod
  1. The first one just removes the audio configuration files
  2. The second command just reboots the audio drivers, the files are then replaced.

This is similar like @user63463 's solution but you don't have to restart your computer :)

done

now pull your audio jack in and out and watch the audio source switch between builtin speakers, headphones, and whatever else like they originally did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .