After applying the Mavericks Update for Mail 1.0, I'm still having the same problems: Gmail works great on iPhone/iPad/Gmail.com, but OS X Mail still does not reflect any changes made on other devices. Also, the recommended settings for Apple Mail on Google's website are uselessly outdated.

Are there any new, up-to-date recommended settings for Apple Mail and Gmail to make them play nicer, has anyone published a good comprehensive blog or anything? (Current as of AFTER the release of the update?)

  • This article maybe of assistance tidbits.com/article/14287
    – Simon
    Commented Nov 13, 2013 at 17:05
  • 2
    It's not really a good answer, but I've been really happy since not using gmail whatsoever with Mail app as I don't like getting caught between gmail's non-standard IMAP and Apple's attempts to keep up with all the ways IMAP ends up broken when gmail is in play. For whatever reason, iOS seems to tolerate gmail better.
    – bmike
    Commented Nov 13, 2013 at 17:18
  • I am not sure why you are having issues, I run mail in 10.8 and 10.7 without any issues, as an IMAP client to gmail. I do however use my own SMTP server. Any changes I make on my iPhone and Android devices are reflected in mail. How often are you updating your mail in OS X Mail? That may be the issue.
    – Deesbek
    Commented Nov 13, 2013 at 23:35
  • +1 Assuming you are referring to Mail Version 7.0 (1822), I have the same issues.
    – Řídící
    Commented Nov 17, 2013 at 14:27
  • Even with the release of Mavericks v10.9.1 Gmail is still not working properly with Apple Mail. It fails to connect with the very same credentials that work fine on iOS.
    – user8472
    Commented Dec 18, 2013 at 5:19

1 Answer 1


Here's what I'd do:

NOTE: I tend to rename folders and prefix them with a '#' instead of moving them. Do whichever you'd prefer.

Delete gmail accounts from mail.app. Close mail and go to ~/Library/Mail. Move it somewhere (delete it later if all goes well). Go to ~/Library/Containers/, and move com.apple.mail. Go to ~/Library/Preferences/, and move com.apple.mail.* Run Mail, and set your accounts up. Go to Mail -> Preferences -> Accounts.

For each gmail account:

  • Turn off Junk Mail.
  • Give them a good name so you can tell them apart.
  • In the SMTP settings, make sure 'use only this server' is checked.
  • In the SMTP settings -> Edit SMTP server list -> give it a good description, change the port to 587, make sure credentials are filled in and SSL is checked.
  • Mailbox behaviours - all checked except junk mail. I set dropdown boxes to never, never, and one month old.
  • Advanced - IMAP path prefix should be '[Gmail]', IDLE checked.
  • I tend to also go to Viewing, and set it back to classic layout. I like enabling the bold unread messages. Then I'll customize my columns.

    Finally, once your email begins to download you'll need to map the sent/drafts/trash folders properly. Send an email and a 'Sent Messages' folder will be created if it doesn't already exist. This is the one Mail uses but not the one gmail/iPhone will use. So click on Sent Mail, and go to the Mailbox menu -> Use this Mailbox for ... -> Sent. Do the same with Trash and Drafts.

    Now if you do have the sent messages folder, I recommend logging in to the gmail web interface at gmail.com, and just move all of those messages to the correct sent folder. Takes about 2 seconds in gmail.com, but will take forever if you try and do the same thing from mail.app.

    Wait for everything to sync up, test sending/receiving from your computer, iPhone, iPad, etc. Make sure the mappings are working out and everything goes where its supposed to.

    If you get sick of mail.app, go and buy MailMate (http://freron.com), which is my new favourite mail client.

    You must log in to answer this question.

    Not the answer you're looking for? Browse other questions tagged .