2

I've read many posts and articles on how to fix this but I'm at a loss as to why nothing I try is working!

I have a number of vhosts setup in my document root which are working fine but for some reason I can't get access to localhost itself, permissions look ok to me i.e. _www has full access to document root and all subfolders

Below is an excerpt from my https.conf:

DocumentRoot "/Users/cduve/sites"

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

<Directory "/Users/cduve/sites">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>

And a screenshot of the finder info for "/Users/cduve/sites":

enter image description here

  • What is the permission on the parent folder /Users/cduve/ ?? – Kent Nov 12 '13 at 2:49
  • Oh -- and, you probably need "Sites" instead of "sites" in the apache config files. If that works, let me know, and I'll put it in the answer section below. – Kent Nov 12 '13 at 2:51
  • @Kent Tried 'Sites' but no joy, funny thing is the vhosts are subdirectories of sites and they work fine but if I try to access them with localhost/vhost1 etc. it's forbidden... Permissions for cduve are rw for cduve r for staff and no access everyone – doovers Nov 12 '13 at 3:02
  • In order to see the subdirectories, then _www (or one of its groups) must also be able to read from the parent directory. The easiest way would be to give everyone read permission of /Users/cduve – Kent Nov 12 '13 at 6:15
  • @Kent Yeah I'll try that now but I'm a bit confused because the vhosts are subdirectories and they work fine! – doovers Nov 12 '13 at 8:07
3

I managed to solve this by checking the error_log file using the tail -f command which included the following error:

[client 127.0.0.1] mod_hfs_apple: Mis-cased URI or unacceptable Unicode in URI: /users/cduve/sites/, wants: /Users/cduve/Sites/

The above error made me fix the case of the document root, the next error encountered was:internal server error so going back to the error_log:

[crit] [client ::1] configuration error: couldn't perform authentication. AuthType not set!: / 

Which was solved by commenting out Require all granted in https.conf

The original set up was on a MBP using the following steps.

The virtual host set up was done as per: http://www.coolestguidesontheplanet.com/downtown/how-set-virtual-hosts-apache-mac-osx-109-mavericks-and-osx-108-mountain-lion

  • Just to point out here, the default error log is at /var/log/apache2/error_log – DisgruntledGoat Nov 12 '14 at 10:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .