I have an Early 2013 Macbook Pro. OS Version is 10.9. I'm using a trackpad connected to the bluetooth. All of the sudden, and at random times, my trackpad will lose its connection and will not reconnect. When this happens, I pull up the Bluetooth preferences and I see:

<< do not localize >...
Name not available

Bluetooth will not turn off at all. Nothing can connect to bluetooth once this happens. I have to do a hard reboot of my laptop to get bluetooth working again. This tends to work for a few hours, sometimes an entire day, but at random, bluetooth seems to go corrupt again.

Anyone else having a problem similar to this? Any hints on fixing it? Also, is there some way I can force a reset of just bluetooth? Maybe by the command line?

  • Trackpad is recognized when I reboot. Here's from system.log around the time it happened: 11/18/13 2:59:36.000 PM kernel[0]: **** [IOBluetoothHostControllerUSBTransport][InterruptReadHandler] -- Received kIOUSBPipeStalled error - retrying: 2. [IOBluetoothHostControllerUSBTransport][InterruptReadHandler] -- Received kIOUSBPipeStalled error - no more retries. 11/18/13 6:55:17.000 PM kernel[0]: [IOBluetoothHCIController][handleACLPacketTimeout] -- Disconnecting due to device not responding (ACL Packet timed out) for connection handle 0xb
    – intargc
    Commented Nov 19, 2013 at 15:47
  • I'm having this issue as well. Macbook Air early 2013, OS 10.8.5. I've noticed that when I go to system/preferences and click on bluetooth, the system jams up (shows me the rainbow swirly mouse) and refuses to open the bluetooth preferences). This problem only started occurring yesterday, and I can't for the life of me figure out what has changed. I've used the same mouse and keyboard for ages.
    – user67451
    Commented Jan 14, 2014 at 17:15
  • I'm having the same problem: apple.stackexchange.com/questions/118783/… - Fortunately I can put my computer to sleep and wait for 20ish seconds until it magically wakes up and Bluetooth works again.
    – Andrew
    Commented Mar 5, 2014 at 14:49
  • Do you get this corruption if you turn off your WiFi? I'm seeing pretty severe corruption on WiFi and have my bluetooth off until it gets resolved. Might you be seeing the same interference but having bluetooth falling down? (mine might be broken too, if I were using BlueTooth on this build but I need WiFi more than BT)
    – bmike
    Commented Mar 6, 2014 at 18:35

2 Answers 2


I found some workaround that will at least spare you a reboot when problem arrives. It may be found here: https://discussions.apple.com/message/23705326#23705326

Shortly, type in terminal:

sudo kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport
sudo kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport

After doing this your devices should reconnect. I have the same OS Version (10.9) and Early 2013 Macbook Pro and it works with my problems with bluetooth keyboard.

  • 1
    You, Sir, are my hero.
    – motto
    Commented Jun 8, 2015 at 15:29
  • worked for me for my magic trackpad saved me a reboot
    – zanedev
    Commented Jul 27, 2015 at 18:10
  • 1
    Created this in my .profile fixmouse(){ sudo kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport sudo kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport } thanks
    – Maxence
    Commented Aug 19, 2015 at 6:36

There have been several significant updates to Mavericks, so the first step would be to run software update and get the OS and any firmware updates installed. Next, you can troubleshoot the issue as follows:

System log

Look at the error messages relative to the blued daemon:

grep blued /var/log/system.log

(this is a command to type within Terminal). Check in this system log if you don't have connexion attempts from an unknown Bluetooth equipment. To be able to detect the intruders note your own Bluetooth address within:

System Information > Hardware > Bluetooth

ex. :

Hardware Settings:
    Address:      A8-BB-CF-9B-07-D8
    Manufacturer: Broad…

Battery check

This system log won't display any information about the battery level. You should check it with Alt ⌥ + Bluetooth menu bar icon: Bluetooth menu bar

Interference check

For this interference analysis, install iStumbler and run it. If you are in such a full of interferences environment, put away the other Bluetooth equipments, turn off your Trackpad, wait 30 s, turn it on. If your problem is the result of Bluetooth interference, this might recover its system connectivity (Bluetooth equipment rotate through the frequencies to use on the same channel than the 802.11g. When 2 of them are on the same channel, they are jaming each other).

You may also analyse the behaviour of your Bluetooth connexion in realtime with MacOS X standard tools:

System Preferences > Bluetooth

press Alt ⌥ to display the actual level of Bluetooth signal: Bluetooth signal level And to go further, open the gear drop down menu to select Monitor Connection RSSI to monitor the connection quality: Bluetooth keyboard monitor start Bluetooth keyboard monitor display

Restart the daemon

If you are able to start a Terminal or access your system through ssh, then you can easily restart blued with these few commands:

ps ax | egrep '[ /](PID|blued)'
/usr/bin/sudo launchctl stop com.apple.blued
ps ax | egrep '[ /](PID|blued)'

The second ps should display a new process ID, confirming you that launchd restarted blued correctly. If blued doesn't restart (PID stays the same) then you are facing a more serious problem to investigate, and you will have an harder kill:

ps ax | egrep '[ /](PID|blued)'
/usr/bin/sudo killall -c blued -KILL
ps ax | egrep '[ /](PID|blued)'

But this isn't a good sign at all. This means that blued was stucked within a system call beyond any possibility to deal with a signal. This is most notably the sign of a bug within the Bluetooth driver or kernel extension.

  • Thanks for the help! I restarted my system so I could regain the trackpad while I was working. When it disconnects again, I'm going to go through these steps to make sure it works. If nothing else, at least I know about blued now and can force a reset.
    – intargc
    Commented Nov 12, 2013 at 4:22
  • Just for more information, I had this happen again recently. Killing blued doesn't seem to help get things rolling again. I have to reboot and it recognizes my trackpad again. I posted what the system log states about bluetooth above in the OP comments. I removed the accepted status on this answer just in hopes to get a more clear solution for anyone in the future that may have this same problem.
    – intargc
    Commented Nov 19, 2013 at 15:49
  • 1
    Could you tell me if blued was killed or on the contrary impossible to kill?
    – dan
    Commented Nov 19, 2013 at 16:06
  • According to the logs, I can kill it with both a sig 15 and especially 9. However, when launchd restarts it, it's still in a corrupt state and doesn't recognize the system name ( still in "do not localize" state ) and it doesn't allow any BT devices to connect to it.
    – intargc
    Commented Nov 19, 2013 at 16:19
  • FYI, I just did another killall on blued, this time it worked and brought back my trackpad. All-in-all, I did about 7 killall's with a mixture of TERM, HUP and KILL. I'm not sure why it decided to start working on this last one...
    – intargc
    Commented Nov 19, 2013 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .