11

I was running out space on the drive where I stored my iTunes media, because every time I opened iTunes, the application would immediately begin downloading TV shows I had purchased on my Apple TV.

How can you stop iTunes from downloading purchased TV shows whenever you open it?

See my answer below

Note: Though it may or may not be entirely relevant to the problem (this bug has bit me across versions of iTunes and OS X), the bug was reproduced and eradicated using iTunes 11.1.3 under Mac OS X 10.9 Mavericks

Possibly related detail: I write possibly, because I've modified where my iTunes media lives outside of the iTunes defaults.

This is a common thing to do, when you realize the space on the meager 128 GB drive that came with your computer will no longer suffice.

This detail also warrants mentioning, because the use case deviates slightly from the norm, and pathing often emerges as the culprit in software-related bugs.

Another possibly related detail: I've moved the location of my iTunes media a couple of times, but didn't delete the old location's directory, which is also a parent directory of my current iTunes media location. I've been meaning to re-organize, but there were music files I didn't want to lose at the time I made to the decision to change the media location a second time.

I mention this, because as a software engineer I've run into stupid bugs and relative vs. absolute path issues simply because a user chose to nest directories awkwardly or carelessly.

Good luck!

15

Ultimately, I was able to stop iTunes from automatically downloading TV shows with the following steps:

  1. With iTunes open select iTunes > Preferences... and click the Store tab
  2. If checked, uncheck checkbox Always check for available downloads
  3. If checked, uncheck checkbox Download pre-orders when available
  4. Click the OK button, and close iTunes
  5. Remove the contents of your Music/iTunes/iTunes Media/Downloads directory. You should be able to do that through Finder or by following these steps:
    1. Open Applications > Utilities > Terminal.app
    2. Type rm -rf ~/Music/iTunes/iTunes\ Media/Downloads/* then press <Enter>to delete the plist file along with all of the downloads of TV shows. (Note: this method removes the files permanently, which is fine since the next step re-downloads them.)
  6. Re-open iTunes. There shouldn't be TV shows automatically downloading any longer when you open iTunes. Breath. Relax. Rejoice.
  • OMG, you ROCK. Thanks! You make a great point about being aware of the iTunes folder location. I ran your command line example, deleted tmp files, but that did not do the trick. I realized that my actual iTunes media folder is on another drive. Once I deleted those files, the download stopped. Breath. Relax. Rejoice! :D – mhulse Jan 31 '14 at 18:29
  • @mhulse thank you :) I'm so glad this helped someone else. – mkelley33 Feb 2 '14 at 6:36
  • 1
    @mkelley33 do you know if this will also prevent automatic downloads of new music purchases, e.g. music purchased on another device? – Travis Northcutt Mar 31 '14 at 17:00
  • 2
    Does anyone know how to undo this terminal code? I put it in and the movies stopped downloading, but now some of my music has an exclamation point next to it saying it has been moved. Thanks! – user79364 May 30 '14 at 15:44
  • 2
    A much better solution, assuming the plist files are in ~/Music/iTunes/iTunes\ Media/Downloads directly (not a sub directory) would be to do: rm ~/Music/iTunes/iTunes\ Media/Downloads/*plist, which will just delete any plist files in the Music/iTunes/iTunes\ Media/Downloads directory – Fake Name Sep 25 '14 at 10:50

You must log in to answer this question.

protected by Community Sep 25 '14 at 11:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .