1

After upgradering to Mavericks, I have been bombarded repeatedly with the following prompt:

Messages agent wants to use your confidential information stored in “” in your keychain [Allow] [Always allow] [Deny]

No matter how many times each option is used, the popup appears again after a very short while (usually less than 15 seconds).

Erasing the Messages.app/iChat-related preference files from ~/Library/Preferences/ did not work.

1

This fixed it for me (though note the caveat at the bottom)

Open /Applications/Utilities/Keychain Access.app, search for message, which in my case came up with two keys that I deleted. This required Administrator rights, though.

iCloud still wonky though

Probably because I trashed some of my preferences. I can live with that for the time being as it is not in my face every ten seconds.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .