3

My laptop Mac goes to sleep even though I have Back to My Mac turned on. What kind of thing is likely to cause this? What kind of steps can I take to fix it?

The Mac that is going to sleep has has OS X 10.8. It works ok if I wake it up by hand.

Edit: Thanks for the responses. I should have mentioned I do not have an Apple router. Back to My Mac used to work without having to ask the computer never to sleep (in System Preferences). Asking it to wake for network access seemed to be enough. Unfortunately, some weeks passed after it last worked and before I tried it again, so troubleshooting is tricky. Asking it to sleep is OK as a work-around, but I'd like to find the real problem.

4

The obvious solution would be to set the Mac never to sleep in Energy Saver Preference Pane. If your home router is an Apple Product, you could enable the bonjour sleep proxy setting on your Mac that's labeled "Wake for Wi-Fi network access" and even a sleeping Mac will be woken when Airport detects the remote control packets coming in for your Mac.

Alternatively, you could use a free program called Caffeine to prevent sleep. Lastly, consider Edovia's free screens connect control panel to prevent your Mac from sleeping.

Scroll to the bottom of the page and download their control panel installer. You would need to make an account with them and then run that control panel - choosing the "prevent your Mac from sleeping" option.

I switch back and forth between using their location service and Apple's and have never had the Edovia software conflict with Apple's or cause any issues.

| improve this answer | |
3

If you have an Apple router, it ought to work according to this knowledge base article they have.

| improve this answer | |
2

It is very simple, open a Terminal and type:

pmset noidle

It will prevent your computer from sleeping until you press Ctrl+C in Terminal.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .