8

enter image description here

Am I the only one, or is there anyone else who finds that shadow ontop of a nearby window annoying?

  • Did this work 100% for you? The answer you selected doesn't work at all in Yosemite. – niico Oct 21 '14 at 11:12
5

You must run this:

defaults write com.apple.dock hide-mirror -bool true; killall Dock

This enables a more transparent dock but also removes the annoying shadow.

Note: this fix is specifically for OS X Mavericks

1

Try …

In Terminal:

defaults write com.apple.dock showshadow -bool NO

– then quit Dock.

Reference

Blacktree Secrets secret 2342.

Hint

The preference pane for Secrets can write the preference and perform the quit.

If the preference does not work as expected, for your Dock to the left

Please be aware of the following bug report in Open Radar –

OS X Mavericks: Left/right Dock should not cast a shadow on windows

– but note that the report was for unreleased build 13A538g of the OS (not for 13A603).

  • doesn't work - the shadow remains – niico Oct 21 '14 at 10:32
0

Disable totally:

defaults write com.apple.screencapture disable-shadow -bool true

EDIT: This is only for screenshot function.

Haven't tried it, but this app should have an option for disable totally.

  • This switch disables the shadow of windows when you're taking screenshots – dersimn Nov 10 '13 at 14:03
  • Ahh yeah I see now. I didnt try the cmd last night. Did you try the app Nocturne? It should contain a option for totally disable it, still havent tried that, just I friend that told me he used it a year ago for that. – JW_ Nov 10 '13 at 14:28
  • Nocturne completely disables shadows (also shadows of windows) dropbox.com/s/tbnhlcw83dkrxyl/… - It works like this if you just want to have a tool for shadows github.com/puffnfresh/toggle-osx-shadows – dersimn Nov 10 '13 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .