Yeah, bought a Macbook Retina, come from a Linux background where this stuff is usually a question of removing via the package manager.

Anyhow, I don't play games on this, it's purely for business/development. But I keep seeing this gamed process that came down with the Mavericks update trying to phone home.

Apart from software update, I don't really want any process phoning home, especially when I paid 2G for the damned thing.

Anyhow, anyone know how I can disable/uninstall/kill this process for good?

  • I didn't want to mess with the binary but turning off all settings in System Preferences>Notifications stopped the final phone homes.
    – toxaq
    Commented Feb 8, 2016 at 6:28

6 Answers 6


I'm not sure how to completely disable the process but I've set up Little Snitch to disallow incoming / outgoing processes associated with the Game Center. It's a useful little program.


Specifically for the gamed service, the following command in one of the posts about a similar topic on the Apple Support Communities worked for me, without any need to modify plists or rename files:

sudo defaults write /System/Library/LaunchAgents/com.apple.gamed disabled -bool true

Changing "true" back to "false" will re-enable it, although I've not tried it.

  • looks good, lets see if apple honor the setting. Commented Apr 29, 2014 at 8:38
  • 10
    You can also run launchctl unload -w /System/Library/LaunchAgents/com.apple.gamed.plist. It modifies /var/db/launchd.db/com.apple.launchd.peruser.$UID/overrides.plist, which has precedence over the Disabled key.
    – Lri
    Commented Sep 19, 2014 at 7:43
  • 3
    For all of you who find this and will try to use this method on El Capitan, you might be disappointed. I just did the launchctl unload method and that works even on El Capitan. Commented Apr 30, 2016 at 10:22
  • Alas, SIP seems to prevent both the defaults and the launchctl method of gamed-disabling on Sierra (as of 10.12.6 -- though I think the launchctl method may have worked on 10.12.5 and before).
    – jhfrontz
    Commented Jul 17, 2018 at 15:35

The first thing to do is open the damn thing and log out of Game Center, and delete whatever it still filled in.


This is a cheap hack:

sudo mv /System/Library/Frameworks/GameKit.framework/Versions/Current/Resources/gamed /System/Library/Frameworks/GameKit.framework/Versions/Current/Resources/gamed.inactive
  • Yeah, that seems to be about the only way to disable that crap. I haven't tried it yet (just blocking it's communication using a firewall) but that seems the only way to turn it off. Commented Jan 11, 2014 at 12:17
  • Cannot do that on OS X El Capitan (without system protection disabled). The launchctl way can be done though. Commented Apr 30, 2016 at 10:21

In Yosemite 10.10.3 the gamed process can be found in /System/Library/PrivateFrameworks/GameCenterFoundation.framework/Versions/A/gamed.

I needed to rename the process to get rid of it, the defaults write and unload suggestions didn't work.

  • See other answers - how does this differ?
    – mmmmmm
    Commented Jun 1, 2015 at 11:34
  • @Mark game kit -> GCF
    – bmike
    Commented Jun 1, 2015 at 11:52

Apple really wants this service to run:

# pwd
# mv gamed gamed.disabled
mv: rename gamed to gamed.disabled: Operation not permitted
# rm gamed
override rwxr-xr-x  root/wheel restricted,compressed for gamed? y
rm: gamed: Operation not permitted
# ls -l gamed
-rwxr-xr-x  1 root  wheel  4430368 Jul  9 04:51 gamed

This was on El Capitan 10.11.6

  • 1
    It's probably SIP protected
    – Tetsujin
    Commented Oct 9, 2016 at 10:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .