2

Recently I received a refurbished iPhone 4s running ios 7. The speaker sound does not work in some applications. For example videos from the Photos app play no sound. However, the ringtone works. Keyboard sounds do not work. The music app does not emit sound either.

I have tried power cycling, updating applications, calling the phone and restoring from backup.

Calling the phone seemed to help as audio returned, but then the same problem resumed about a day later.

EDIT 1: This problem is intermittent. For example when unlocking the first two keys make sound but the third and fourth do not. It does not always fail in this pattern. One moment the sound may be working on youtube, and go silent the next. There does not seem to be any pattern to the failures.

What can be done to fix this?

  • Did you try to return it to the vendor and exchange it for a non-defective unit? – nohillside Nov 8 '13 at 6:20
  • No, I have not done that yet because it seems like a software problem rather than hardware. – Jim A Nov 8 '13 at 19:20
  • I ended up exchanging the unit for a non-defective unit. I read that switching hardware units from one that runs ios 6 to one that runs ios 7, then syncing ITunes (where ITunes expects a device running ios 6) may be at the core of the issue. I have not found a definitive cause for this problem, however. – Jim A Feb 24 '14 at 20:46
  • @JimA Do you have the "sound switch" enabled? You should not see the orange color on the left of your iPhone. Applications ignore this switch sometimes. – Rob Apr 12 '14 at 9:52
  • @Rob Yes, the sound switch was enabled. – Jim A Apr 28 '14 at 19:45
2

i had exactly the same issue. Cleaned the charging socket + the earphone entrance. Voila! it was working again

1

I had a similar problem…

  • I had no sound playing on phone speaker from any application / music, but the phone rings and I can talk to other parties and rasise and lower the volume with the buttons
  • The volume + and - buttons had no effect and I had no control over rasing or lowering volume in a phone idle situation, or within any application except when in setting mode under sound while selecting a tone — the selected tone is played and the volume buttons can then operate normally for that particular purpose only. The same is applicable to the alarm clock settings when selecting a tone from within the clock applications. Sound was also available in voice recording application (built in iOS 7 latest update).
  • In all other cases there was no sound and no control over volume. When pressing the volume buttons I get a screen that says ringer on top but I cannot control it

If you have this problem, it has nothing to do with hardware or earphone sockets, charging socket, etc. The problem only occurs if you have updated your iPhone using OTA update. For some reason updating over the air causes the system to trigger the sound and volume problem.

  1. First back up your phone on iTunes so you can restore data later.

  2. Keep the phone connected to itunes and enter the phone into a DFU mode as follows:

    1. Press the power button and home button simultaneously for 15 seconds.
    2. Release the power button while keeping the home button pressed for another 15 seconds.
    3. Release the home button.

    Your screen would turn to pitch black as it is now in DFU mode. If the screen is anything but black repeat the sequence above until you get the pitch black screen.

  3. At this particular time when you are correctly in DFU mode, iIunes will show a message stating that your phone needs restoration. Press Restore.

  4. iTunes will start downloading the latest version of iOS 7 — do not unplug the phone or power off computer.

  5. Once downloaded, message will appear to ask you to restore hit restore and wait for the process to continue.

    Once phone restarts you can now restore your data back up that you have created on your computer or iCloud that you have created before you started this process.

The phone sound will not return immediately — give it a couple of hours to allow systems to reset and there you go your phone is working again.

0

Just clean the charger port using clean toothbrush and blowing air into the port...it could be because of some dust particle.

0

Check the following things:

  1. Is your ringer switched to off?
  2. Is DND (Do Not Disturb Mode) on?
  3. Has your iPhone / Apple Product had water damage recently or in the past?
  4. If you plug in headphones does it work?
  5. Is it glitched into headphone mode?

The answer to most is simple and you can also try restarting.

-1

I had the same problem till I discovered that iOS 7 had turned on the DND (Do Not Disturb). Once I turned off it worked perfectly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .