0

I installed a new HDD and transferred my old data to it by using dd on my old HDD and then dd again to the new HDD. However, when booting from the new HDD, it does not recognize the new, larger disk space, and still thinks it has the old size.

My old HDD was 160 GB and it was near capacity, new HDD is 1TB.

The command I ran to write to my new harddrive was

>: sudo dd if=/dev/rdisk3 of=/dev/rdisk0s2 bs=131072

>: df -h
Filesystem      Size   Used  Avail Capacity  Mounted on
/dev/disk0s2   149Gi  146Gi  2.4Gi    99%    /

>: diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            999.9 GB   disk0s2

How should I fix this? I can run another round of dd again if need be.

1 Answer 1

1

dd copies the filesystem exactly, byte by byte. It is not the best way to duplicate a filesystem, however, now that it is done, you can use Disk Utility to resize. Select the Drive (not partition), then Partition tab, and you can drag the partition to the desired size.

7
  • In Disk Utility, there is only the one partition, and it believes it has the full space (1TB)
    – nidoran
    Nov 8, 2013 at 3:27
  • This looks OK. What makes you think the size is wrong. Have you tried verify/repair in Disk Utility. The best option may be to use Disk Utility Restore to copy to the new disk, which is what you should have done. You will need to boot to recovery mode to do this.
    – Milliways
    Nov 8, 2013 at 3:52
  • I think it is wrong because my Finder only shows 2 GB available, when it should be about 850 GB. Disk Utility shows "Capacity: 1TB, Available: 2GB, Used 150GB." I will try verifying with Disk Util. But the reason I cannot use DU Restore is because I only have an older version of Mac OSX install disk. I want to use the newer version of Mac OSX from my old HDD.
    – nidoran
    Nov 8, 2013 at 4:08
  • You boot into Recovery by holding down ⌘+R on restart. You don't need install disk
    – Milliways
    Nov 8, 2013 at 4:15
  • Are you sure this is the best option? I just verified the disk and I got this message: "This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk."
    – nidoran
    Nov 8, 2013 at 4:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .