3

I'm trying to use an Epson Workforce 840 over Wifi with Mac OS X 10.9. This Mac has never used the printer before.

I've tried going through the usual steps but it's not working. My Mac sees the printer over Wifi, and I select it. But the response is that "The software for this printer is currently unavailable. Please contact the printer’s manufacturer for the latest software."

Then I go to Epson, and they just tell me to do the same thing I just did.

If I try to add the printer in System Preferences, it also sees the printer over Wifi, but I get the same result. If I click the "Add Printer..." button, choosing "auto select" for the driver produces a message reading "Software for this printer isn't available from Apple. Contact the printer's manufacturer for the latest software."

Lather, rinse, repeat.

But: I have two Macs running Mavericks, and one of them can use the printer. The one where it works "inherited" its printer driver from Mac OS X 10.8, I believe. The one where it doesn't work has never used this printer before.

How do I break this loop and get the printer working?

0

I eventually found Apple's instructions for how to reset the Mac OS X printing system. Once I did that, the usual automatic download worked.

  • If you have found the solution, please mark it as solved. Thanks – Pratik Nov 8 '13 at 9:38
  • I know, but it's not possible to accept your own answer until two days after posting that answer. I'll mark it as accepted when the site permits me to do so. – Tom Harrington Nov 8 '13 at 16:21
  • Sorry Tom, I did not see the date. – Pratik Nov 8 '13 at 20:10
  • Hmm, in my case I have installed the manufacturer's driver (Xerox Phaser 6500DN) but when I go to add it I continue to get a similar prompt "The software for this printer is currently unavailable. Would you like to use generic software for printing?". Resetting the print system did not help. – natevw Feb 19 '15 at 17:04
  • I was trying to add the printer directly via the "Nearby Printers" section of the [+] button in "Printers & Scanners" prefpane. By using the actual "Add Printer or Scanner…" atop the same menu I was able to select the same printer and it added just fine with the proper driver O_o – natevw Feb 19 '15 at 17:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .