3

I open "Preferences" in Mail, uncheck "Store drafts on server" and save (Gmail account). However, when I open the preferences again, the "Store drafts on server" (or whatever it says in English version) is checked again. It really pisses me off. How can turn it off permanently?

I use OS X Mavericks.

2 Answers 2

5
+50

Another good option that fixed the problem for me is as follows:

  1. Quit Mail.app.
  2. Log into Gmail in your favorite web browser.
  3. Click on the gear menu and select Settings.
  4. Click on the Labels tab.
  5. Under System Labels, next to Drafts, click on show if unread and uncheck the Show in IMAP box. Now disable Store draft messages on the server.
  6. Launch Mail.app.
  7. Select MailPreferences…
  8. Click on the Accounts button in the toolbar.
  9. Click once on the account name and then click the Mailbox Behaviors tab.
  10. Uncheck the Store draft messages on the server box.
  11. Close the window and opt to save your changes when prompted.

Source: Apple Support Communities: Mavericks Mail app and Gmail Drafts folder

3
  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone.
    – Daniel
    Commented Nov 11, 2013 at 17:48
  • Had the same problem. This fixed it for me, thanks!
    – Rolf
    Commented Dec 30, 2013 at 9:59
  • Any solution for the same problem but not using Gmail as the e-mail service? Commented Feb 19, 2014 at 9:02
1

Are you using Mavericks? This is probably related to the MANY Gmail related problems that have cropped up since it's release.

You are in luck though, as Apple has just released an update to solve many of said problems.

http://www.macrumors.com/2013/11/07/apple-releases-mail-update-for-mavericks-to-address-gmail-issues/

2
  • Yes, I use Mavericks. I'll try the update and see how it works.
    – vtvs
    Commented Nov 8, 2013 at 9:36
  • The update has not helped.
    – vtvs
    Commented Nov 8, 2013 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .