1

It seems that OSX does not behave well with hotspots.

By hotspot, I mean the wireless networks which opens automatically a window for login/password such as

enter image description here

when you join them.

When you login for the first time to such a hotspot, there is no problem.

The problem occurs when to try connect later. I think OSX tries something like putting automatically your login/password, but it doesn't work. But the result is that the window to connect never shows up.

I had such a problem few months ago on OSX 10.8 and it was difficult and unclear how to solve it. It involves keychain and other things.

It seems that this problem still exists on OSX 10.9.

So is there an easy way to avoid these problems?

1

From your screenshot it looks like your browser is opening (and later failing to open) a login screen in a new window. Try using a different browser.

You might also try

System Preferences -> Network -> [with "Wi-Fi" selected] Advanced -> uncheck "Remember networks this computer has joined"

and / or

Keychain Access -> [with "System" keychain selected] -> delete the AirPort network password

  • No, it's not the browser window. When you connect to such a network, OSX automatically opens this window. – Colas Jan 24 '14 at 11:59
  • 1
    I'm sure that you are in fact looking at some kind of browser window; check out the URL the bottom of your screenshot, "eduspot.inlalco.fr/login?......". You might also try deleting your cookies from your browsers. – earlio Jan 25 '14 at 20:18
  • Mac OS X has built-in functionality to detect hotspot redirects, and will automatically open a window to allow authentication (maybe just a Webkit view?). This is not a part a browser, and as far as I know, there is no way to control this behavior. – lid Dec 24 '14 at 10:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .