2

I am using S/MIME self-signed certificates for email encryption across iOS and OS X. Creating the certificates and installing them (including the CA) worked perfectly. Also using them on OS X worked as expected.

Using them on iOS however only works in part. The certificate and the CA are installed, whenever someone sends me an email I can reply to just fine and the response would be equally encrypted.

The problem I am running into is when I want to compose a new email. The recipients email address appears in red and the lock symbol next to it is open. When I tap on the email address I get the following error message:

An encryption certificate for "dummy@example.com" could not be found on the server. Without a certificate, you can't encrypt messages sent to this address.

What's wrong? As I said, replying to an email works fine. I am also not sure "server" iOS is talking about here.

Any help is greatly appreciated!

You must log in to answer this question.

Browse other questions tagged .