2

I recently upgraded MacBook Pro (Retina, 13-inch, Early 2013) operating system from Mountain Lion to Mavericks. Since then several WiFi networks are rejecting my password (rejecting wrong passwords immediately, and giving timeout for correct ones) or even not showing up in the WiFi list. In the meantime, some other networks are OK.

Is there a post-upgrade task to clean up or reset the Wireless configuration or drivers?

What I've tried:

  • Removing saved wifi records from Network preferences - Advanced
  • Removing wifi passwords from Keychain Assistant
  • Removing Wi-Fi profile from network preferences and recreating it
  • Changing the Service Order with Wi-Fi to top (under the gear next to +/-)
  • Unfortunately I often have no access to routers to reboot or change channels
  • Have you checked these places? ... Click wifi > open network prefs > wifi > advanced > preferred networks (use minus to delete). Also, /Applications/Utilities/Keychain Access.app > System (delete wifi login) and local items > delete wifi login – y3sh Nov 9 '13 at 15:09
  • Yes, tried that. No difference. – elomage Nov 20 '13 at 7:47
1

My new MacBook Air was effected by this problem (but the old white MacBook was not). Here's what I did 2 days ago in System Preferences in this order: renew DHCP Lease, uncheck Keychain in iCloud, and then restart the computer. So far so good.

0

I renewed DHCP lease (but I guess this doesn't do anything when the computer isn't connected to a network?), deleted the network, rebooted, and then I was able to connect.

0

For others finding this thread because they too have the problem:

On my wife's MacBook Pro, the answer turned out to be that the laptop could not differentiate between the 2.4GHz and 5GHz version of the wireless, and if it connected to a different one previously, OS X told her the password was wrong.

The cure was to 'split' the two wi-fi networks by adding '-5' to the 5GHz version SSID, then the Mac could tell them apart. It has the same pass code for both networks (although they could be different pass codes) and is now happy to connect to either, every time.

Why this suddenly crops up for some may be traced to relative signal strength on each frequency, and maybe a new router having the 5GHz band for the first time, but with the same SSID. (That is how they are normally set up, but Apple has problems with this setup.)

HTH someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .