3

I know that this has been posted several times and each time it's a slightly different description. Neither one fits to the behaviour on my iMac (Mid 2011 / 32GB RAM) nor does any of the solutions solve it.

But, long story short. Any app from Office 2011 for Mac (Word, Excel or Powerpoint) crashes upon rightclick with the same error message.

from MERP it says:

Microsoft Error Reporting log version: 2.0

Error Signature:
Exception: EXC_CRASH (SIGTRAP)
Date/Time: 2013-11-05 19:43:30 +0000
Application Name: Microsoft PowerPoint
Application Bundle ID: com.microsoft.Powerpoint
Application Signature: PPT3
Application Version: 14.3.8.130913
Crashed Module Name: merp
Crashed Module Version: 2.2.4.130913
Crashed Module Offset: 0x00004422
Blame Module Name: MicrosoftComponentPlugin
Blame Module Version: 14.3.8.130913
Blame Module Offset: 0x0000c4d8
Application LCID: 1033
Extra app info: Reg=en Loc=0x0409
Crashed thread: 2

so I took Solution 1 that i found (Update MERP to version 2.2.8) --> without success :-(

it didn't update correct somehow, in Finder it shows as Version 2.2.8 but in it's report it lists itself as version 2.2.4

Now I found Solution 2 (re-install 14.3.8 aka SP3) --> no success either :-(

MERP now displays version 2.2.9 in Finder but still 2.2.4 in it's report.

Solution 3 was disabling MERP --> didn't help so far but shed some brighter light on the issue as follows

Process:         Microsoft Excel [301]
Path:            /Applications/Microsoft Office 2011/Microsoft Excel.app/Con-
tent/MacOS/Microsoft Excel
Identifier:      com.microsoft.Excel
Version:         14.3.8 (14.3.8)
Build Info:      Unknown-130913~0
Code Type:       X86 (Native)
Parent Process:  launchd [154]
Responsible:     Microsoft Excel [301]
User ID:         501

Date/Time:       2013-11-05 20:35:44.179 +0100
OS Version:      Mac OS X 10.9 (13A603)
Report Version:  11

Crashed Thread:  4  Dispatch queue: com.apple.datadetectors.dynamiclookup

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', 
reason: 'condition "DDABAddRecord should not be called with NULL type"'

Everything else that i tried before was:

  • uninstall Office 2011 German completely according to MS KB 23987668
  • install Office 2011 German
  • update MERP and MS AutoUpdater
  • uninstall Office 2011 German completely according to MS KB 23987668
  • install Office 2011 English
  • switch OS language from German to English
  • update MERP and MS AutoUpdater
  • ... (the above mentioned follows here)

SideNote: I have no issues with Office 2011 for Mac German on my MacBook Pro (late 2009 / 8GB RAM) on German Mavericks and I had no issues before with OS X 10.8.5

Any further hints to solve this issue are very welcome!

2

Thanks to the folks from bitprotect I got this solved by following their description. (in German here: http://www.bitprotect.de/loesung-abstuerze-von-office11-nach-upgrade-auf-macos-10-09-maverick/)

for all others, the short summary is:

  1. disable MERP

    • Go to /Library/Application Support/Microsoft/MERP2.0
    • open Microsoft Error Reporting.app
    • go to Preferences and uncheck "Enable Microsoft Error Reporting"
  2. open Terminal

  3. execute "defaults write com.Apple.Finder AppleShowAllFiles TRUE;killall Finder"
  4. in Terminal go to /Library/Contextual Menu Items
  5. delete all files and directories in this folder "rm filename" or "rm -r directoryname"
  6. execute "defaults write com.Apple.Finder AppleShowAllFiles FALSE;killall Finder"

open office program and rightclick to check if it works. --> yes it does!

optionally you can now re-enable MERP.

1

I had a similar problem - MS Office crashes after the Mavericks update. The problem was solved once the following recent update was manually applied to Office. Hope it helps.

http://www.microsoft.com/en-us/download/details.aspx?id=40352

  • not even 14.3.9 works here – brainray Dec 8 '13 at 11:35
1

The Office 14.3.8 update did NOT work for me but the following DID. This was via phone with a Microsoft Level 2 Tech Support agent - they are aware of this issue with Mavericks and will be releasing an update in the next month.

  1. Restart your Mac in Safe Mode (press shift key when the initial screen is blank, release it when you see the progress bar in grey Apple icon screen)
  2. Go to System Preferences/Users & Groups/Login Items
  3. Remove any items which have a warning triangle next to them (unlock if you see them greyed out) and are tagged as "Unknown"
  4. In Applications/Font Book, go to File/Restore Standard Fonts...
  5. After "Proceed", you should get an all clear
  6. Try to open any Office application (still in Safe Mode) - they should be fine
  7. Restart and have a cup of tea
  8. :)
0

Many people have written that the only working version of Office on Mavericks is the English one. There seems to be a language issue (I have the German version 14.3.9 which still crashes).

You must log in to answer this question.

protected by Community Feb 2 '14 at 13:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .