0

Whenever I receive an email in Outlook that has either a word doc or excel attachment it only allows them to be opened as "read only" documents. How can I have them open as regular documents as they did with Entourage 2008? Thanks.

1

This is a feature of Office 2011 Outlook. The behaviour is not limited to Mavericks or Word or Excel files.

When you double click an attachment to open it, a copy is saved under your Library folder (in ~/Library/Caches/TemporaryItems/Outlook Temp). This folder is not generally visible or intended to be accessible to users hence the "Read Only" attribute of the file.

You can either

  • double-click the attachment in Outlook (to Open it in its default application) and then Save As... to, for example, your Documents folder before editing or
  • right-click and Save As... in Outlook itself, in which case the file will not be "read only".
0

I'm not sure if it's a good idea, but you could try giving yourself write permission to ~/Library/Caches/TemporaryItems/Outlook Temp with chmod.

0

If you click on the "preview" button next to the attachment file name in the message header and then click "Open with MS Word" on top of the preview it will open as a regular word document that can be edited. Works the same with Excel and presumably other file types, though I haven't tried any others.

0

Here is the easy work around.

In your email, either preview the attachment by clicking the preview button in the email, or click on the attachment and press spacebar (both will preview the attachment). In the actual preview window, there is a link to "Open in Microsoft Word" or "Open in Microsoft Excel". When this link is clicked from the preview pane, it opens as the full version, not a read only version. Solution obtained!

-1

You can't. They did it on purpose so you don't accidentally ruin the original.

  • not true, you can unlock it just click the down tab next to locked in the title and it gives you the option to unlock. still v annoying that there is no universal fix tho – user77591 May 7 '14 at 1:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .