4

Is there a workaround? How can I fix this? These files are on SMB shares to Windows servers with a NTFS file system. Is there a better way to connect to windows shares? Please guide as I am new to the Mac world. Thanks.

  • I have no problem tagging files on my linux box serving over AFP. I can only assume that you are using an unsupported file protocol. – Brad Allred Nov 5 '13 at 17:30
  • 2
    Make sure you have write access to that network volume/directory/file. Also, I would be very surprised if tagging worked for FAT or NTFS remote volumes. I would also be surprised if tagging worked when the remote volume is shared via SMB. – HairOfTheDog Nov 5 '13 at 18:18
  • 2
    Please supply more info. i.e what is the format of the Network drives, Connection protocol file types, blah blah blah. One of the nuggets you provide may help someone help you. – markhunte Nov 5 '13 at 18:30
  • months late... but are you using BlueHarvest etc to clean up dot underscore files on network volumes? – Tetsujin Dec 17 '14 at 16:10
  • No. I am not using anything like that. – aseem Jan 15 '15 at 15:31
2

I'm also having this problem. I've seen a few users comment on it on different forums and Apple's Support. No one has offered a real answer, other than this seems to be a problem with Apple's implementation of SMB or the way the Finder interacts and reads those Volumes (or the way attribute files are saved/stored/read on them).

The format of the servers volume doesn't really matter and should be transparent to the client. All Finder can see is a SMB share, whether that share is on an ext3 filesystem or a NTFS one is quite irrelevant.

I've tested connecting to the same volume with AFP, SMB (which in Mavericks now uses SMB2 by default) and CIFS (forcing Finder to use the SMB v1 protocol). As far as I know, tags info are stored in .DS_Store files for each folder.

Connecting with CIFS or SMB, tag support is buggy. Tags sometimes appear for a few seconds and then disappear. In addition to the .DS_Store file, a ._FILE_NAME file is created for each file. Getting the properties of the file sometimes shows the tag.

Connecting with AFP tags work as expected. Just a .DS_Store file is created. But no tag info is available if tag was assigned while mounted as SMB.

Is a pity, because SMB2 is faster than AFP in my tests, but sacrificing tags for it is too bad.

0

I think there are some problems from Apple's side regarding this. I have had files on shared Dropbox folders that is getting tagged (by others) and messing up my local tags. So there are some problems here I think.

0

The reason why tags work in dropbox, is because dropbox keeps a copy of the files on your local drive, these tags are not indexed on the network, so when other use shared folders on your dropbox, they are not checked, and you will see the tags as soon dropbox syncs with your mac

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .