0

I've been using iWork for a while and have created some pretty elaborate designs in Keynote and Pages, but I haven't come across a problem like this before or even an option to link/embed images.

In Keynote, all my images are now linked to an external source on my hard disk, rather than embedded in the file itself. When I attempt to copy media in any manner (alt-drag or cmd+c/v or duplicate a page), a grey "placeholder" box is produced with a question mark in the middle and a diagonal line across it (see top right corner of the image).

It only works when the source image is in the same place on my hard disk.

When I insert an image or other media file (insert -> choose) into Keynote, there doesn't seem to be an option to link or embed like there is in other applications such as Adobe Illustrator or InDesign.

Why is Keynote all of a sudden treating images in this fashion? How can I fix this to re-enable embedding of images?

enter image description here

1
  • Just to add: I haven't upgraded to Mavericks yet and I'm still running Keynote '09 (5.3)
    – Orun
    Nov 5, 2013 at 15:59

1 Answer 1

0

go to Keynote > Preferences > under general Preferences make sure under Saving: "include Preview in document by default" and "copy auto and Movies into Document" is checked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .