7

My screen (desktop/spaces) keeps jumping to the first "desktop". There are no running apps on that desktop (except finder). After the first few times this happened I pressed ⌘ Cmd-⌥ Opt-⎋ Esc and restarted finder.

When it continued to happen I quit all open apps and restarted the computer. (I run a few apps full screen, and usually keep the first desktop open for any quick work or apps I will use, if I will have an app open for a while that doesn't have full screen, I create a desktop/space for it and run it off on the side somewhere).

The screen just keeps taking me back to the first one. It is getting to the point where it is too annoying to ignore. So far typing this I have counted it happening seven times.

What I have tried, besides restarting Finder, and restarting the Mac, in Mission Control settings I disabled Automatically rearrange, and Group windows by applications (to be honest I don't know what Group windows by application means, I assume it has to do with what screens a new window of an already running app will open on), and When switching to an app, switch space.

I tried rearranging spaces, I moved the Desktop to the third space (this must be a Mavericks feature, I don't think I have ever been able to do that before), and it keeps jumping to that Desktop (third space). I have also tried creating a new desktop space and deleting the old one. It keeps jumping.

I also don't think this is finder calling for anything. The menu bar remains the same for the app I was using, and only becomes finder when I click on the desktop.

I could just not use spaces, but what would the point be?

I don't know if this would be an easy thing to help anyone with, but maybe something similar has happened to someone before.

5
  • Perhaps this is relevant: apple.stackexchange.com/questions/108333/…
    – Lizzan
    Nov 5, 2013 at 9:45
  • Thank you very much, that describes exactly what happens, I have tried what was suggested. Nov 5, 2013 at 9:54
  • If this works, is there a way I can close the question? Nov 5, 2013 at 9:54
  • write an answer to the question and tick it
    – Jonatan
    Nov 5, 2013 at 9:59
  • As this is solved, I can't add an answer so a comment will do. My issue was caused by a dialog box in screen #3 of outlook in screen #1. Find the screen that triggers the switch and look for it there. But to do that, you need to move the offending app to it first.
    – Roy Falk
    Sep 17, 2020 at 5:57

2 Answers 2

3

Same thing here. Would appear to happen only when the WiFi is connected, but on further research into this it appears to be related to Google Drive. Close the Drive sync application or disconnect from Wifi and it's ok.

5
  • The problem seemed to have gone away for me when closing Google Drive. I will reopen Google Drive, and if it happens again I will disconnect from Wi-Fi and see if it makes a difference. Nov 5, 2013 at 11:03
  • the worst answer EVER... :) but funny one...
    – Ewoks
    Aug 16, 2014 at 18:31
  • Thanks, this helped. I closed Google Drive but the problem persisted. It disappeared only after I disabled Wi-Fi. (So no, it isn't the worst answer ever...)
    – MJV
    Jun 11, 2015 at 16:37
  • I have a similar problem, but it jumps to the third Space on my primary display (I have a monitor connected) when I try to go to a specific Space. Disabling WiFi and Google Backup & Sync didn't resolve the issue. If I drag the offending Space into a different order, the problem persists and follows the Space. No solution yet.
    – davidA
    Dec 6, 2017 at 7:40
  • In my case it was VirtualBox. Jul 3, 2019 at 4:09
8

It is Google Drive, it's causing Finder to crash and restart, which is why it keeps jumping back to the first desktop.

It's related to the "Show file sync status icons and right click menu" setting. If you turn this setting off in the Google Drive preferences, the problem should go away.

1
  • I will reopen Google Drive, if I get that jump to desktop I will try this. Nov 6, 2013 at 14:39

Not the answer you're looking for? Browse other questions tagged .