0

I upgraded to 4.3, without jailbreak. Phone seemed ok, but I turned it off and on again a few days later (normal power off). It started rebooting itself. I tried hard resets.

Eventually got to a stage where it needed the SIM unlock code but was otherwise working. Unlocking the SIM froze the device when the signal bars first showed (trying to register on the network, I guess). I tried resetting the network settings, no help.

I did a complete restore this morning, setup as new device, activated (officially unlocked). Still the same problem. Someone at work connected it to XCode on Mac, said they didn't really do anything, and it started working. I turned it off, on again, and it has the same problem. Any ideas?

  • When you restored it and set up as a new device, did you eventually restore a backup or you left it "empty"? Did you later sync with your iTunes account or your computer? – Martin Marconcini Mar 25 '11 at 11:14
  • Always failed on contract SIMs that I tried, worked on a PAYG one. – Sam Brightman Mar 27 '11 at 14:50
  • @Martin: normally I restore from backup & re-sync, but in this case I left it fresh & unsynced to be sure. – Sam Brightman Mar 27 '11 at 14:50
1

You might be lucky, iOS 4.3.1 is out and there's the following change in the changelog:

Resolves bugs relating to activating and connecting to some cellular networks

Try to update and tell us if it fix the problem.

  • I noticed this morning, am just restoring to it now – Sam Brightman Mar 27 '11 at 14:54
  • @Sam let us know how it went :) – Martin Marconcini Mar 27 '11 at 15:03
  • Wow, that is one horrible bug. 4.3.1 looks to have fixed it perfectly. – Sam Brightman Mar 27 '11 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .